• Resolved LSBK

    (@lsbk)


    Hi
    I use WP 5.2.2 without Gutenberg and Theme 2014

    The bullets before each entry show one line above. On a iPhone it looks horrible.
    but also on a desktop.

    BTW can I switch off the bullet at all?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author David Gwyer

    (@dgwyer)

    I’ve just checked out your sitemap page and the issue with the blank bullet line is to do with some injected styles.

    It appears as though you have a lot of ::before and ::after selectors everywhere in your markup. One of these is adding table styles to the sitemap unordered list element that contains the whole sitemap. Perhaps you’re using a page builder plugin?

    You should be able to fix this with CSS, something like (untested):

    .simple-sitemap-container ul li:before {
      display: block;
    }

    There are options to configure sitemap output in the pro version. To turn off the sitemap icons you can use this shortcode:

    [simple-sitemap types="page, post" list_icon="false"]

    • This reply was modified 2 months, 1 week ago by  David Gwyer.
    • This reply was modified 2 months, 1 week ago by  David Gwyer.
    • This reply was modified 2 months, 1 week ago by  David Gwyer.
    • This reply was modified 2 months, 1 week ago by  David Gwyer.
    Plugin Author David Gwyer

    (@dgwyer)

    Let me know if this is still an issue. Closing for now.

    LSBK

    (@lsbk)

    Hi David,
    Sorry for the delay, I wanted to try also on my office computer.

    I installed the fix as described
    Result:
    Desktop (Win7, Firefox) displays ok; (Win10 Chrome) error
    SAMSUNG Galaxy Tab A6 with Firefox runs oK, Chrome error
    iPhone 8 (iOS 12.3.1) with both Chrome & Safari error (both portrait & landscape)

    error means no change in behaviour

    Plugin Author David Gwyer

    (@dgwyer)

    The snippet may need to be tweaked to work on all browsers. As I said the problem stems from the injected ::before and ::after pseudo selectors that are everywhere in your code.

    You should be able to correct this by adding custom CSS as I posted before but with modifications as necessary.

    LSBK

    (@lsbk)

    Hi David,
    I’m not that experienced. I added your snippet to style.css of my child theme.

    We have now the same problem with a parallel site after upgrade of the plugin to 3.2
    any idea?

    Plugin Author David Gwyer

    (@dgwyer)

    Does your other site contain the same pseudo selectors as the first one? If so then this is the likely cause of the issue on the second site.

    The CSS I posted was a patch to help with the issue to help you get started. But you’d likely need to get help (i.e. paid) to fix it if you don’t have the experience.

    I’ve seen this a couple of times before where page builder type plugins inject a load of markup everywhere which can break other plugins.

    If you still need help then please use the contact form via the free plugin to discuss options. I’m sure I can help get you sorted.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.