Bulk WP Smush.it - help (8 posts)

  1. tfraley
    Posted 4 years ago #

    Good day,

    I have just installed Smush.it current version.

    I am trying to use Build Smush.it to smash all my images.

    But it seams to do maybe the most a hand full of images before it stops
    I've been trying to do this all day today and last night

    I have a little over 400 images on my blog.

    Is something timing out ? any way to quick fix this

    It works fine if i start it again and gets another 5 or and keep having to repeat the steps
    Leaving it doesn't seem to do much. I left it over night and it didn't get very far.

    thanks in advance

  2. Alex Dunae
    Posted 4 years ago #

    Are you getting an error message, or is it just hanging?

  3. vampired
    Posted 3 years ago #

    I've had this problem as well. Since I am running Varnish, I get a "guru meditation error".

  4. troid
    Posted 3 years ago #

    hi, vampired you problem is solved easy
    just add port from you web server
    put here "8080" you port.

  5. vampired
    Posted 3 years ago #

    I am running varnish on port 80.
    Nginx is running on 8080, but is not exposed to the Internet.

    It works, but only does some, then throws the error. If I keep doing it over and over, it would eventually finish all 2,000 images. (Probably only 25% of them are not smushed yet and some due to size).

  6. troid
    Posted 3 years ago #

    me to, the same conf varnish 80 nginx 8080. i run the script direct on port 8080 nginx and worked.
    one more thing, try on varnish conf "default.vlc"
    increase guru timeout
    the line is:
    .firts_byte_timeout = 300s
    300 = 5 min
    may put 30 min or 2 hours xD.

  7. vampired
    Posted 3 years ago #

    That might have done it, I just changed it to 6000s (was not specified in the default.vlc I created) and kicked it off. So far it has been running for about 3 minutes, which is about 1 minute longer than it would run before.

    Thank you!

  8. vampired
    Posted 3 years ago #

    Now it goes for about 3-4 minutes, and I get a message from CloudFlare the site is offline. Got to check into that with Cloudflare.

    Thanks again, that looks like it resolved the Varnish timeout.

Topic Closed

This topic has been closed to new replies.

About this Topic