Support » Plugin: AWS for WordPress » Bulk Update not working

  • Hi,

    the plugin works very good, thanks very much!

    But when I tried converting all current posts to speech, the Query, that gets created, seems to so slow, that my mysql-server works over 2h without giving any feedback to the plugin (that’s a guess, the server sends data, but the plugin does nothing with it…) – no speech gets generated. I tried it a couple of times, but it never does anything.

    When updating posts by hand it works very good and the speech gets generated.

    I tried increasing different buffers and cache settings of the mysql-server, but the query is quite costly (many joins, that slows down things a lot). At one time I stopped the server a few minutes after clicking “bulk update” and the slow-query-log said, the query already read about 21mio rows… on our website we have about 1600 posts entries.

    Maybe an option to bulk-convert by category would help in this issue, so we could bulk-update a few hundred posts at one time…

    I also tried updating posts using wp_update_post and wp_insert_post, but these functions did not call the amazon_polly_save_post filter, so no speech gets generated.

    Any help would be appreciated.

    Regards,
    Mirko

Viewing 1 replies (of 1 total)
  • Plugin Contributor tstachlewski

    (@tstachlewski)

    Hi @miwalter,
    I’m sorry for the problem. Bulk operations are tricky, that’s why I didn’t enable this for Translate functionality. But I also have to say, that we didn’t have this kind of problem reported for many months. The functionality is working like this, that it takes only subset of posts, which are then converter, then it takes another subset etc. – so there should not be a problem like you mention… but… hmmm… I will leave the case open, I will deep dive into it AFTER the next release of the plugin. (probably not before September).

    Once more time, sorry for the problem.

    Cheers,
    Tomasz

Viewing 1 replies (of 1 total)
  • The topic ‘Bulk Update not working’ is closed to new replies.