Support » Fixing WordPress » Bulk plugin deactivate – wordpress dead!

  • Resolved Alex997


    I was troubleshooting possible conflicts with a new plugin, so I tried to do a bulk deactivation across all plugins.

    Now WordPress is completely unresponsive – white screens for the admin console, and white screens for the user blog.

    As my hosting company doesnt provide me access to any Apache error logs I assume this is a database connectivity issue.

    I can connect to the database fine through MyPhpAdmin and queries run ok. Just nothing via the WordPress php files.

    I have tried changing the plugins dir to plugins-bck to deactive them all just in case there is a conflict – but no improvement.

    I have database backup files from 2 days ago, and the database can be exported via MyPhpAdmin no problem so I am not worried about loosing everything.

    Please could someone advise what to do next?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Jan Dembowski


    Forum Moderator and Brute Squad

    It’s probably not that bad if it’s plugin related. If you have FTP or file access to your WordPress installation, try renaming wp-content/plugins to wp-content/plugins-old and see if you can get into your dashboard after that.

    Thanks Jan, but I already said in my original post that I tried that.

    I personally think it’s a database connectivity issue now. Perhaps all the network sockets are stuck in a TIME_WAIT and won’t allow new sockets to open.

    If I had control of this system (I am an IT enterprise architect/engineer by trade) I would restart Apache, restart the database and hopefully the sockets would free up.

    Is there a WordPress API that I can use to check database connectivity?

    As I say, I can connect fine through MyPhPAdmin to the database, and no files have been changed.

    That link you sent me, this is already present so the bulk deactivation must have worked…

    Use phpMyAdmin to deactivate all plugins.
    – In the table wp_options, under the option_name column (field) find the active_plugins row
    – Change the option_value field to: a:0:{}

    One of the plugins was WSD Security – which locks down a lot of WP. I wonder if deactivating this can cause such issues?

    I wonder if I can turn all the plugins back on again via the database?

    Moderator Jan Dembowski


    Forum Moderator and Brute Squad

    Sorry, totally missed that (must keep repeating “Reading is fundamental”…)

    If you have file level access to wp-config.php you can enable debuging to see if those errors will display. Or even see if you can get your own error log generated (if that works with your install).

    If that works it should help you figure out what’s going on.

    I wonder if I can turn all the plugins back on again via the database?

    Probably can, not sure where that’s documented. See if you can get the debug or error log to see what’s going on.

    FIXED IT!!

    wp-config.php has this in it before:

    /** Enable W3 Total Cache */
    define('WP_CACHE', true); // Added by W3 Total Cache
    * The base configurations of the WordPress.

    And after I disabled all the plugins it looked like this:

    * The base configurations of the WordPress.

    ie. the W3 Total Cache plugin forgot to put a carriage return back in the php file after it stripped out its contents and as a result the whole file was effectively commented!!

    WIll be reporting this to W3 Total Cache!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bulk plugin deactivate – wordpress dead!’ is closed to new replies.