Support » Plugins and Hacks » [Resolved] Bulk Page Block Not Working

[Resolved] Bulk Page Block Not Working

  • Thank you for creating this plugin, it works great!
    I have found one issue with it though. If you try blocking several pages as a bulk action it will send you to the “All Posts” page saying this: “3(Or whatever number of pages you tried to block) posts 0.000000e+0d.” Then if you go back to the “All Pages” page it will say those pages that you tried to block are now blocked. Then if you look at each of the pages that you just blocked they will say they aren’t blocked.

    Trying to bulk action block pages currently doesn’t work. You must go into each individual page to block them. Can you fix this problem?


Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Chad Butler


    Thanks for mentioning this. It appears that in general the bulk blocking/unblocking is working. However, there are some cleanup issues that need to be addressed (and will be addressed in an update).

    First, the messaging is not working (which is why you are getting the exponential number as part of the message).

    The other, and more problematic issue is that one method is using “1” as a value and the other is using “true”. So there is a compatibility problem with displaying whether a post is blocked or not.

    I’ll probably address this in conjunction with another related “issue” – the “block” and “unblock” custom fields are legacy way back to very early versions of the plugin. While I don’t usually like to change things like this, we really outgrew using two custom meta fields quite some time ago. I intend to do an update that will do away with “unblock” and simply rely on one meta field. There will be a db update as part of the update so users don’t have to go update all their posts. But this will cleanup the plugin, standardize things in a manner compatible with other plugins (such as Advanced Custom Fields), and should also solve the issue in this post.

    So – it’s on the list 😉

    Thanks for all your help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Bulk Page Block Not Working’ is closed to new replies.