Support » Plugin: WPCore Plugin Manager » Bulk Installation Error

  • Love the Plugin,

    However, i am running a fresh WP Core install with the WP core plugin. Everything works unless I try to install more then one plugin at a time. I tried different configurations to weed out a particular PI but it seems it is not case specific. I have no errors installing via the collection list individually.

    Any guidance on this would be very much appreciated.

    Thank you,
    Jeffrey

    The error output is below:

    Warning: sprintf(): Too few arguments in W:\wamp\www\sandbox\wp-admin\includes\class-bulk-upgrader-skin.php on line 154
    Call Stack
    # Time Memory Function Location
    1 0.0015 262264 {main}( ) ..\plugins.php:0
    2 0.0024 305864 require_once( ‘W:\wamp\www\sandbox\wp-admin\admin.php’ ) ..\plugins.php:10
    3 0.6324 26937904 do_action( ) ..\admin.php:222
    4 0.6324 26938344 WP_Hook->do_action( ) ..\plugin.php:453
    5 0.6325 26938392 WP_Hook->apply_filters( ) ..\class-wp-hook.php:323
    6 0.6325 26938896 call_user_func_array:{W:\wamp\www\sandbox\wp-includes\class-wp-hook.php:298} ( ) ..\class-wp-hook.php:298
    7 0.6325 26939216 TGM_Plugin_Activation->install_plugins_page( ) ..\class-wp-hook.php:298
    8 0.6329 26946904 TGMPA_List_Table->process_bulk_actions( ) ..\class-tgm-plugin-activation.php:751
    9 1.3723 27564440 TGMPA_Bulk_Installer->bulk_install( ) ..\class-tgm-plugin-activation.php:2985
    10 1.3788 27573160 TGMPA_Bulk_Installer->run( ) ..\class-tgm-plugin-activation.php:3382
    11 1.3788 27573520 WP_Upgrader->run( ) ..\class-tgm-plugin-activation.php:3266
    12 2.3629 27574160 TGMPA_Bulk_Installer_Skin->after( ) ..\class-wp-upgrader.php:757
    13 2.3630 27574544 Bulk_Upgrader_Skin->after( ) ..\class-tgm-plugin-activation.php:3646
    14 2.3631 27574664 sprintf ( ) ..\class-bulk-upgrader-skin.php:154

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author stueynet

    (@stueynet)

    Interesting. Is this a clean wp install or do you have themes and plugins as well?

    Yes it is a fresh install. Just default plugins and using TwentySeventeen theme. I would note that this is on a local wamp environment.

    I’ll run this up on a stage server and see if there is any difference. I am starting to worry there could be a timing out issue locally but that is just a guess. If indeed this is specific to my wamp then no big deal as installing the list one at a time from the managed collection is still more efficient then my current process. I’ll get on testing this on a stage setup and update.

    Thank you

    Plugin Author stueynet

    (@stueynet)

    So this appears to be an issue with the TGM plugin activation library which we use. However it only is an issue on older versions of PHP. It looks like you may be running PHP 5.3?

    https://github.com/TGMPA/TGM-Plugin-Activation/issues/669

    Here is more info on the issue. TGM has pushed an update which will be released in their next version. In the meantime I will try and patch it.

    That makes sense. I can just as easily bump up my php version as well. Do you happen to know the oldest version that would work adequately with the Plugin?

    I do appreciate the prompt replies. Even before your insight I was committed to buying the Lifer License on this plugin. The management and accessibility of my plugin collections, even sans the bulk install option, is worth it’s weight in gold.

    Thank you,
    Jeffrey

    For clarification I am currently running php version 5.5.12

    I took a look at the solution you mentioned and you nailed it. I replaced the line in question in “class-tgm-plugin-activation.php” and the bulk install works as it should. I haven’t experienced any other fallout but I suppose that is possible. If you have any other concerns or advice I’d appreciate.

    Again thanks for the quick response,
    Jeffrey

    Plugin Author stueynet

    (@stueynet)

    Ok good to hear. I have not had a chance to confirm it’s based on php version. I only tested on my test server and did not have the same error. I am hoping the next version of TGM will be released soon. I will try and hotfix it this week anyway.

    Which replacement do I have to make? I have the same issue in my installation. Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Bulk Installation Error’ is closed to new replies.