WordPress.org

Support

Support » Plugins and Hacks » WangGuard » [Resolved] Bulk Check Sploggers button reported most of my users!

[Resolved] Bulk Check Sploggers button reported most of my users!

  • I imported new user using a plugin. After they were imported it showed that they had no status, so I selected all of the users on the first page and clicked the Bulk Check Sploggers button. That worked fine and everyone got a green “checked” status.

    Then I went to the next page of users and did the same thing. This time, however, they all got a red Reported as Splogger status. So, thinking that I might have click the bulk report button by mistake, I went to the third page of users, selected them all and very carefully clicked the Bulk Check Sploggers button. The same thing happened, everyone was reported as a splogger.

    I had to go through each one and click “Not a Splogger”, which changed the status to Checked(forced). If I click recheck after that it says “reported as splogger”. That means that WangGuard still considers them to be sploggers, even though they are not.

    http://wordpress.org/extend/plugins/wangguard/

Viewing 7 replies - 1 through 7 (of 7 total)
  • If you are testing a custom registration form, or manually adding multiple users you should always turn off the IP filtering feature, or temporarily disable WangGuard. Failing to do so could result in a panic attack because your IP gets blocked by WangGuard for a few hours when there are a bunch of registrations from it.

    Hopefully WangGuard will make the IP checking ignore administrators in a future update.

    Oops.. double post..

    Plugin Author Jose Conti

    @jconti

    Hi ELsMystERy,

    Not check the administrator IP, means having to capture the admin’s IP on every page he visit. It could mean unnecessary overhead for the server.

    So then it should always be checked unless adding or testing registrations?

    Plugin Author Jose Conti

    @jconti

    You have to uncheck “Do NOT verify client IP address” unless you are testing the registration page.

    If that option is checked, you don’t sent the IP to WangGuard server so you will never be banned (your IP).

    That’s actually what I meant to say, just forgot the “un”. Thanks for the help with all of this. I hope that this helps anyone else who makes the same mistake in the future.

    Plugin Author Jose Conti

    @jconti

    You’re welcome

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Bulk Check Sploggers button reported most of my users!’ is closed to new replies.
Skip to toolbar