Support » Plugin: Pods - Custom Content Types and Fields » Build-in-Taxonomies selected, but not shown

  • Resolved tommy83

    (@tommy83)


    1. We installed theme that share extra menu in backend: recipe posts.
    Taxonomie name is: recipe
    If you click on “create new recipe post” you will see some extra fields in right sidebar. For example: recipe category.

    2. Now we created via pods an custom post type.
    After this we moved to Pods Admin -> Edit Pods -> Advanced Options.
    Scrolled down to section “Build-in-Taxonomies” and we selected “Recipe Categories” to show this box also in our custom post type.

    But its not shown in our custom post type.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same problem. But I solved it by enabling the Rest Api for the Pods category

    Plugin Author Jory Hogeveen

    (@keraweb)

    But I solved it by enabling the Rest Api for the Pods category

    Correct, the REST API is required for the block editor.

    tommy83

    (@tommy83)

    Thank you for that fast feedback @keraweb and @gakradmin

    I already set that option to active in REST API tab:
    https://ibb.co/9pKR3FF

    Now move to ADVANCED OPTIONS tab and select she options for wordpress post sidebar:
    https://ibb.co/3WrHs50

    Click on save and now switch to new post type/taxonomie and open single post. The sidebar have some options, but no one for recipe tags and recipe categories:
    https://ibb.co/QCRRNGj

    Also in post settings (view settings/panel for sidebar) all settings are active:
    https://ibb.co/WPzGkNn

    What i am doing wrong? Thats realy strange.
    We are using latest wordpress and tested with php 7.3 and 7.4.
    No caching plugin used. Hosting based on kinsta managed server.

    tommy83

    (@tommy83)

    Tested on latest version of wordpress. Same issue.

    • This reply was modified 2 months ago by tommy83.
    tommy83

    (@tommy83)

    This issue is only when gutenberg editor is active. When i activate the classic editor: everything is fine. 🙁

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @tommy83

    Sorry for my late reply. But I think you’ve forgot to enable REST on the taxonomy as well, not just the post type.

    If it still won’t show after that it’s probably a plugin conflict: https://docs.pods.io/faqs/plugin-theme-conflicts/

    Cheers, Jory

    Plugin Author Jory Hogeveen

    (@keraweb)

    Closing topic due to no reply. Feel free to re-open if you still need help!

    Cheers, Jory

    tommy83

    (@tommy83)

    Thank you for your feedback.

    But I think you’ve forgot to enable REST on the taxonomy as well, not just the post type.

    Coud you send me screenshot where i can find this settings?

    If it still won’t show after that it’s probably a plugin conflict: https://docs.pods.io/faqs/plugin-theme-conflicts/

    We done this steps already:
    Turn off all plugins. not help.
    Also “Health Check” plugin” not showing any issue. Tested with latest wordpress + php 7.3 and php 7.4

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.