Support » Plugin: podPress » bugs WP3.2 podPress8.8.10.8

  • Resolved ip_tara

    (@ip_tara)


    I just have updated my WP to 3.2 and podPress to 8.8.10.8 and some bugs appear.
    1) I usually use category casting. If I change the category casting options the xml of this category doesn’t change. I can even delete the category but the xml remains. I need to re-save any post for the category for changing takes effect.
    2) Options iTunes:Summary, iTunes:Subtitle, Blog/Podcast title and Description (Tagline) seem like unwork. I usually use custom values and Use Category Name and Use Category Description but it seems like Use Global and Append Category Name usage.
    To repair these bugs I have had to return to podPress 8.8.10.7 but only second problem was resolved.

    http://wordpress.org/extend/plugins/podpress/

Viewing 15 replies - 16 through 30 (of 34 total)
  • Is that category feed? Or is it a podPress Feed? What are your settings for Description (Tagline), iTunes:Subtitle and iTunes:Summary?

    It is a category feed. I have enabled category casting.
    Description (Tagline) Use category description in both English and Japanese
    iTunes:Subtitle Insert custom value in both English and Japanese
    iTunes:Summary Insert custom value in both English and Japanese

    <itunes:subtitle> and <itunes:summary> of this feed (<channel>) are having the same content at the moment. The <description is different. iTunes uses that as a the summary if the <itunes:summary> does not exists (see http://www.apple.com/itunes/podcasts/specs.html#summary).

    Thank you for the explanation!

    Since the latest upgrade, iTunes is reporting our feed as invalid:

    “The Expert Witness Radio Show >> Podcast Feed” does not seem to be a valid podcast URL.

    The feed was working fine until the upgrade – for a long time now.

    Site: http://www.expertwitnessradio.org

    Thanks!

    Plugin Author ntm

    (@ntm)

    @iamediaworks: Which is your current podPress version?

    (@IAmediaworks and also @meetwp: Please, consider to open a new thread next time. The problems in your blogs have most likely nothing to do with the first topic of this thread. Thanks.)

    Sorry about that! Current version: 8.8.10.9

    Thanks!

    Plugin Author ntm

    (@ntm)

    Thank you for the version number and for reporting the problem. I know where to look now and will probably fix this today or tomorrow.

    Plugin Author ntm

    (@ntm)

    @iamediaworks: I have uploaded a patch. It is part of the current Development Version. I would appreciate it if could try this version.
    (You may need to clear the cache memory of your feed reader/feedburner/feed cache plugin in case you use such software.)

    Plugin Author ntm

    (@ntm)

    @meetwp: I don’t know wether installing the current Development Version will help in your case or not. But you may try it.
    I’m still not sure why the itunes:summary in http://feeds.feedburner.com/meetitalia-travelkaiwa is shorter as it should be.
    But I have noticed a difference to the itunes:summary of the English feed (http://feeds.feedburner.com/meetitalia-travelphrases). The itunes:summary of this feed contains certain line break characters which are not in the Japanese feed.
    Please, control the itunes:summary input of the Japanese feed and remove all line breaks in that summary as test.

    Hey…

    How do I do this without losing all of our settings?

    Thanks!

    m.

    Plugin Author ntm

    (@ntm)

    @iamediaworks:

    • Make a backup of your data base.
    • Download the Development Version .zip file.
    • extract the .zip file on your local computer
    • upload the extracted files and folders to your blog (so that they replace the old files and sub folders which are usually in /wp-content/plugins/podpress)

    That is it.
    But it is a good idea to download the 8.8.10.9 .zip file and if something is not working then install this version the same way.

    THANK YOU!!!!!

    WORKED!!!!

    Thanks SO much.

    @ntm Understood, next time I’ll do a new post!
    Sorry for posting here.

    I had taken out the line breaks trying to test if they were the issue.
    I have pasted plain text.
    I have also tried to change the summary field form custom to global.
    Nothing changes I always get the following text

    <itunes:summary>ミートイタリア・トラベル会話は、あなたの旅行の、言葉のお供です。ポッドキャストのレッスンは、旅行で役立つ基本フレーズを勉強するための助けになるでしょう。文法にはとらわれないでください。イタリアでのコミュニケーションの中で、何が重要となるか、そのことに焦点を当ててくださいね。より深い学習のためには、練習用のトラックとPDFファイルの併用をお勧めします。</itunes:summary>
    Maybe it’s stuck in a cache?
    Is there any way to clear a feed cache in podpress?

    Thank you

    Plugin Author ntm

    (@ntm)

    Maybe it’s stuck in a cache?

    Yes, maybe.

    Is there any way to clear a feed cache in podpress?

    podPress does not cache the feed. But Feedburner and the some cache plugins for WP blog do it. Also web browser or feed readers tend to cache feeds. (I’m using Firefox to get a first look of rss feeds. In order to see modifications, I need to clear the browser cache before each reload.) But since I get this text to, the problem might not be the browser cache.

    Maybe use the original feed URL to control the modifications: http://ja.meetitalia.org/category/travel-phrases/feed/
    The subtitle and the summary look different to ones in the Feedburner version:

    <itunes:subtitle>このシリーズでは、文法事項の分析は行いません。その代わりに、外国でのコミュニケーションにとって必要なことに焦点を当てていきます。それぞれの課は、一つかそれ以上の短い会話から始まります。それらの文章を、いつ、どのように使っていくのかを勉強します。各課の後には、練習用のトラックがついています。学んだばかりのことを早速実践してみるためにも、ぜひ利用してみてください![...]</itunes:subtitle>
    <itunes:summary>Just another MeetItalia.org site</itunes:summary>

    The summary settings seems to be “Use Global” at the moment.

    I have made a further little test and inserted the long itunes:summary text (which you have posted above) into a category feed of my test blog:
    “http://undeuxoutrois.de/wp/category/allgemeines/podcast/feed/”
    It was no problem.

    Maybe try it again in your blog and control the result in the original feed.

    Hello, the above text is fine as it is in both description and subtitle.
    Can you try pasting this in your feed?

    ミートイタリア・トラベル会話は、あなたの旅行の、言葉のお供です。イタリア語レッスンは、旅行で役立つ基本フレーズを勉強するための助けになるでしょう。文法にはとらわれないでください。イタリアでのコミュニケーションの中で、何が重要となるか、そのことに焦点を当ててくださいね。より深い学習のためには、練習用のトラックとPDFファイルの併用をお勧めします。

    ミートイタリアのプレミアメンバーに登録すると、イタリア語の『学習コンテンツ』にアクセス出来ます!
    イタリア旅行に行く前の、イタリア語の勉強にピッタリ!

    プレミアメンバーになれば、

    『学ぶ』
    100項目以上のイタリア語トラベル会話の学習コンテンツにアクセスして勉強できる!

    『トレーニング』
    ネイティブみたいな会話が出来るようになる為に、イタリア語トラベル会話のトレーニングトラックにアクセスして、実際に発声練習が出来る!

    『楽しむ』
    学んだ内容で面白いクイズを楽しめるから、更に身に付く!

    I wonder if the 『 are breaking the code.

    I’ve now also tried to use the Summary Burner in feedburner.

    I have been testing first of all the website category feed, here

    But still had the same problem.
    I clear the cache before reloading a new feedvalidator page

    So to recap at the moment the japanese text in this post is in both the WordPress Summary and in Summary Burner on feedburner.

    Thank you!

    Plugin Author ntm

    (@ntm)

    I wonder if the 『 are breaking the code.

    It does not seems to be a problem. I have copied and pasted this last section into the itunes:summary field of the category feed and it is in the feed in full length. The feed is still valid.
    But if this is no Japanese character then I would not use it.

    I clear the cache before reloading a new feedvalidator page

    Which cache do you clear?

    What do you mean by “WordPress Summary”? The category description or the iTunes:summary of this category (the one among the Category Casting options) or something else?
    The category description and the iTunes:summary of this category are to different things but they should contain them same content.

Viewing 15 replies - 16 through 30 (of 34 total)
  • The topic ‘bugs WP3.2 podPress8.8.10.8’ is closed to new replies.