Support » Plugin: WP-Optimize » Bugs found with WP 3.9RC1

  • Test conducted with forthcoming wordpress version 3.9. Latest test conducted on WP 3.9RC1. Installing WP Optimize plugin on top of WP 3.9RC1 displaying the following two error messages.
    1.At the top of the plugin’s administration page just above the head line “Database Optimization Options” the following error found:
    Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in some-path-to-root-directories\wp-content\plugins\wp-optimize\wp-optimize-common.php on line 333
    2.Second error at the Data Tables Report:
    Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in some-path-to-root-directory\wp-content\plugins\wp-optimize\wp-optimize-main.php on line 395

    https://wordpress.org/plugins/wp-optimize/

Viewing 5 replies - 1 through 5 (of 5 total)
  • also same problem …

    Warning: mysql_query() [function.mysql-query]: Access denied for user ‘……… (using password: NO) ………../wp-content/plugins/wp-optimize/wp-optimize-common.php on line 332
    Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in /………./wp-content/plugins/wp-optimize/wp-optimize-common.php on line 332
    Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /…………/wp-content/plugins/wp-optimize/wp-optimize-common.php on line 333

    esmi

    (@esmi)

    Forum Moderator

    @event22: It is considered impolite to interrupt another poster’s ongoing thread unless you are posting a solution or suggestion. As per the Forum Welcome, please post your own topic.

    Plugin Contributor ruhanirabin

    (@ruhanirabin)

    @bv. I will get back to you on this.

    @event22, it seems you are having DB or Files permission issues

    @ruhanirabin
    Appreciate your response to this bug.
    On production (live) sites we didn’t find this error. But on local server like in XAMPP, MAMP we found this bug. We are expecting that other members also get same issues on local development but not on their production sites. Hope this help to find the root cause for this bug.

    Plugin Contributor ruhanirabin

    (@ruhanirabin)

    @reviewkeys, I found the problem.. some of the SQL queries needed to convert to $WPDB calls. The problem would appear on 3.9+ only.. if you are up for a testing version do let me know.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bugs found with WP 3.9RC1’ is closed to new replies.