Support » Plugin: WP Job Manager » Bugs for Translations V 1.33.4

  • Resolved welshlamb10

    (@welshlamb10)


    Hi,

    There appears to be an issue using Polylang with the latest update of WP Job Manager.

    This specifically effects custom fields e.g. – hours

    Whatever is entered into the field on English e.g. 27 hours per week
    Will then appear on both English and the Alternative language job advert.

    If you change the Alternative language to e.g. 27 awr yr wythnos
    This will then reflect on both Alternative and English language job advert.

    Please advise (this has only happened since the latest update).

    Thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • Custom fields added how? Manually through PHP?

    Hi @tripflex,

    Theres no heavy customisation. Using Jobify theme, polylang and WP job manager.
    The issue only seems to happen with featured jobs.

    Any ideas?

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Hi @welshlamb10 , you didn’t answer the question though. How were the custom fields added? Can you share screenshots of the problem? Or a link to the site?

    @richardmtl, my apologies.

    Yes sorry my mistake, yes I am using the plugin ‘field editor’. I’m unsure which are standard fields tbh (I need to check). This issue has only happened since last update.

    Here’s a link:

    Eng:
    https://charityjobfinder.co.uk/en/job/team-support-officer/

    Welsh:
    https://charityjobfinder.co.uk/cy/job/swyddog-gwasanaethau-cynorthwyol/

    This is a featured job listing – it only effects feature listings. I can’t figure out why. But I’ve added a test job and it worked perfectly.

    Thank you so much for your time, I really appreciate it

    Hi @richardmtl @tripflex ,

    I have this under content-job_listing.php (in child theme):

    <div class="job_listing-logo">
    		<?php jobify_the_company_logo( 'small' ); ?> <p>
    		</p>
    	</div><div class="job_listing-about">
    
    		<div class="job_listing-position job_listing__column">
    			<h3 class="job_listing-title"><?php the_title(); ?></h3>
    
    			<div class="job_listing-company">
    				<?php jobify_the_company_name( '<strong>', '</strong> ' ); ?><br>
    				<?php the_job_field('job_summary') ;?>
    				<?php jobify_the_company_tagline( '<span class="job_listing-company-tagline">', '</span>' ); ?>
    			</div>
    		</div>

    Hope this helps.

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Additional note:

    Open thread with Polylang: https://wordpress.org/support/topic/bug-wp-job-manager-featured-jobs/

    In a duplicate thread (which is now closed https://wordpress.org/support/topic/bug-translations-on-feature-jobs/) you said “This issue is only effecting ‘featured jobs’.”

    Now, can you confirm if this happens if you switch to a default theme instead of your child theme?

    hi @richardmtl,

    Thank you for getting back to me. I have the same issue when using just the standard theme (not child theme), so think this is not a theme issue.

    Thanks

    • This reply was modified 2 months, 3 weeks ago by welshlamb10.

    @richardmtl – just to confirm I’ve tried alternative themes and appear to have the same issue.

    Hi @richardmtl @tripflex,

    Is there any update on this?

    Thanks

    Hi @richardmtl,

    I have had the theme dev’s look at this. They believe it is relating to the ‘feature’ jobs setting as part of the WP Job Manager plugin. I’m hoping to get this resolved.

    This is the response they sent

    However, I do not think this is based on the reference you have added using the get_job_field() function, to incorporate the custom job listing value since the issue only occurs when a job is set as featured. It seems as if WP Job Manager is making a change to a singular post, which is the typical behavior. Polylang is trying to keep multiple job posts custom values (both the original and translated versions) in sync and, in that process, is not able to accomplish this once the featured status kicks in. Since the “Featured” status is from the WP Job Manager plugin, I would still suggest consulting the plugins’ support on this matter. The issue also does not seem to be widget-based as can be confirmed from the page here, of which still uses the same page template

    Plugin Author Jake Morrison

    (@jakeom)

    Hi there,

    I’ve re-opened the original Github issue for this with reproducible steps. I’ve also found a fix and put it in a pending PR for 1.34 (no ETA).

    https://github.com/Automattic/WP-Job-Manager/pull/1876

    Jake

    Hi @jakeom,

    Thank you for this.

    Appreciate it.

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Since the PR for this issue has been merged and will be included in our next update, I’ll mark this thread as Resolved. If the 1.34 update (when released, no exact date yet, sorry) still doesn’t fix it, re-open the thread or create a new one. Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.