Support » Plugin: Flexible Shipping for WooCommerce » Flexible shipping triggers tax error

  • Resolved MikaelG

    (@armbreaker)


    Hi.

    I have during the last month tried to figure out why I had problem with zero tax setting for one of the countries I sell to. I have gone through all kinds of support channels with WooCommerce and so on and was about to give up, when by accident found out it was your plugin causing this. But it wasn’t obvious and a somewhat rare situation that causes this.

    If I add a country (in my case Norway) to the list of countries to sell to but don’t add any shipping methods (except pick-up & free shipping with discount code) then the bug appears for tax settings. If I set a tax setting (for example 0% VAT or 5% VAT) for this country this setting is totally ignored in all parts of the store incl. cart & checkout as long as Flexible shipping plugin is enabled. The prices are displayed with default VAT included and it doesn’t matter what I set that specific country’s tax to. If I add a shipping method, just one, using Flexible Shipping, then the tax setting is working again for that country. And if I disable the plugin, the tax setting is also working again.

    Would really appreciate if you could fix this, as I had to disable sales to Norway for now due to this issue.

    [ Please do not bump. ]

    • This topic was modified 3 months, 2 weeks ago by  MikaelG.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor dyszczo

    (@dyszczo)

    Hi MikaelG,

    thank you for precise description. We will try to replicate and fix it as soon as possible.

    Best regards,
    dyszczo

    Plugin Contributor dyszczo

    (@dyszczo)

    Hi MikaelG,

    We can’t reproduce the issue :/
    Could you provide as with more info? Maybe screens of your tax and shipment settings and WooCommerce system status?

    Best regards,
    dyszczo

    Plugin Contributor Marta Pawlonka

    (@martapaw)

    Hello @armbreaker,

    As we haven’t got any replies, I’m marking this topic as resolved for now.

    Best regards,
    Marta

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.