Support » Plugin: Forget About Shortcode Buttons » BUGGY VERSION

  • Resolved pucelo2000

    (@pucelo2000)


    New 2.0 version is not even a beta. If you have more than one button in a post, it mixes links and adds “no follow” chain to the links in a random way.

    Please, fix it.

    Thanks for your work.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I have returned to the previous version of the plugin. The website is very active and can not afford experiments. Thanks.

    Plugin Author DesignsAndCode

    (@designsandcode)

    Hi there

    I understand.

    Is there any way to replicate your issue so that I can work on it?

    The beta was in testing for ages, and you are (so far) the only user with this issue.

    So, its likely there is a plugin conflict, and I’ll need to see the issue in order to resolve it.

    I can provide access to a blank dev site if you’d be willing to install your theme / plugins so we can recreate your issue.

    Let me know.

    Best

    Plugin Author DesignsAndCode

    (@designsandcode)

    Hi again pucelo2000

    I found your issue with mixing links! Jeez this was a big one, I think I created it in the last few tweaks I made before release :/ Thanks for letting me know.

    Anyway, if you update to version 2.0.1 (just released, might not show for a while) this will be fixed.

    RE nofollow:

    When you create a button with nofollow, FASC adds rel="nofollow", but, when you save your post, or change html view, WordPress changes *some* of them, inconsistently, to rel="nofollow noopener noreferrer"

    I do not plan to solve this for now as it looks like a WP issue, and technically, nofollow is working now, the only behavior not desired is WP modifying nofollow in anchor tags.

    Please let me know how you get on ๐Ÿ™‚

    Best

    Thanks. When I update to 2.0.1 I will let you know. Anyway, great work.

    Hello, I updated to 2.0.1 and there are 2 news:

    The good one is that mixing links is fixed. ยกGreat!

    The bad one is that when you edit a post, all the buttons not edited change its link (for instance), from http://bit.ly/test01 to http://bit.ly/test01%20nofollow , and that is not a nofollow link but a 404 link. If you edit the button, not even changing nothing in the button, the link is OK, but if you edit anything in the post but the button the link is corrupted with “%20nofollow” chain.

    I have to come back to version previous to 2.0.0

    Plugin Author DesignsAndCode

    (@designsandcode)

    Hmmm

    I had a user report something similar.

    Did you try clearing your cache (both browser, and WP) before testing it again?

    This did the trick for the user I mentioned, although the issue was entirely different.

    I’m not sure what is causing your error now in this scenario, the latest version is working well for me in all my tests, even with the nofollow.

    Anyway, if the above doesn’t work, then we are startiong to look at environment specific issues.

    I would think I’ll need to setup a site with your theme & plugins.

    Would you be ok to upload them if I create a dev site for us to work on?

    Best

    Yes, sure. Tell me when it is ready.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @designsandcode I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials on these forums.

    http://codex.wordpress.org/Forum_Welcome#The_Bad_Stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

    Plugin Author DesignsAndCode

    (@designsandcode)

    Just updated the plugin, added WP 4.8 compatibility too (it broke some things for us).

    Let me know how you get on – I hope this resolves your issues.

    Thanks

    Everything fixed now. The bad thing is that opening editing window to insert or change the link is slower than previous versions in wich it was possible to change links without opening edit.

    Thanks.

    Plugin Author DesignsAndCode

    (@designsandcode)

    I’m looking at adding this back in as a feature ๐Ÿ™‚ watch this space

    Thanks ๐Ÿ‘

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘BUGGY VERSION’ is closed to new replies.