Support » Plugin: Download Monitor » Bug with W3 Total cache

  • Resolved kliyo35

    (@kliyo35)


    Hello,

    I would like to activate the plugin W3 Total Cache but when I do, links of my downloads don’t work. How can I configure the 2 plugins together ?

    Thank you !
    ————————————————————————————–
    Bonjour à tous,

    J’aimerais utiliser le plugin W3 Total Cache mais quand je l’active les liens de mes téléchargements ne fonctionnent plus. Comment je peux configurer les 2 plugins ensemble ?

    Merci !

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same here.

    Hello,

    Can you please share the exact error you see when both plugins are activated?

    It just show whichever post has a download link a blank page.

    Hello Angelica,

    Have you modified any of our templates? If you are not sure, please delete and reinstall our plugin and then switch to default WordPress theme and test again. Let us know what you find.

    Hello,

    There have been no replies to this topic, so I’m marking this as resolved. Please do let us know if you’re still experiencing an issue.

    Thread Starter kliyo35

    (@kliyo35)

    Hi,

    Unfortunately my client’s website is online. I can not afford to cause bug and change the theme. But the settings are by default. I did not change anything. I use Divi theme.

    The issue is different on each browser. And none works.

    Hello,

    “W3 Total Cache” has a lot of options, and it’s simply not possible for us to know what would be causing the issue without testing it.

    I would suggest either setting up a testing/staging site using the same contents of your clients site (most decent hosting companies offer this nowadays) and if that is not possible, I’d recommend enabling WP Debug for some time, test the download and see if the errors are recorded.

    Thread Starter kliyo35

    (@kliyo35)

    Hello,

    I copied the whole site to test. I enabled WP_Debug but no error message. I tried the default theme and same problem.

    What can I do for you to know what is causing this issue ?

    Thank you for your help.

    Try enabling on function at a time in w3 total cache, maybe you’ll find out.

    Thread Starter kliyo35

    (@kliyo35)

    I disabled all of my plugin. I reset default settings of W3 Total Cache. I updated WordPress to 5.1.1. I deleted all transients of Download Monitor. It doesn’t work.

    I installed a new WordPress with only Download Monitor and W3 Total Cache. I changed nothing in settings. And it works. I don’t understand.

    Hello,

    Try enabling other plugins one at a time and test every time to see if our plugin works.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Bug with W3 Total cache’ is closed to new replies.