Support » Plugin: Modern Events Calendar Lite » Bug with Tooltip/Pop-up in Monthly View, pop-up not working

  • Joe B

    (@joelogic)


    Hi

    I have noticed that when if there are two or more events in the (current) month, the tooltip/pop-up works ok.

    I have this issue on several sites, and have tested the MEC plugin with the latest version of WordPress on all sites, with all plugins disabled, and with a variety of themes.

    Tested using 3 live sites, 2 using PHP Version 7.4.6, and 1 using PHP Version 7.2.34and my Localhost/WAMP server, Apache 2.4.41, PHP Version 7.4.0

    Also, with the tooltip/pop-up, in the bottom left-hand corner, there is a comma, followed by 3 dots. I have located them in here,

    /wp-content/plugins/modern-events-calendar-lite/app/skins/monthly_view/calendar_simple.php

    around line 105

    $tooltip_content .= !empty($event->data->content) ? ‘<div class=”mec-tooltip-event-desc”>’.$event_content.’ , …</div>’ : ”;

    They appear to not be of any use, they look as though they may be for a ‘read more’ link.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Webnus

    (@webnus)

    Hello @joelogic,

    We need to know the steps to replicate.

    I would then forward it to the developer team to fix the issues in the upcoming updates. There is nothing to be worried about; we will fix the issues. I also appreciate you for reporting the issues.

    Please send details as steps to reproduce in a fresh WordPress.

    Also, can you please provide some info on the plugins and the theme you have too?

    ____________________
    You can use an online service to upload your screenshots/files:

    https://wetransfer.com/
    https://www.dropbox.com/
    https://postimages.org/
    And etc…
    Or send them to us via this email: support@webnus.net.

    Best Regards

    Thread Starter Joe B

    (@joelogic)

    Hello

    Thanks for the reply. So, there are two issues.

    1. The pop-up does not work when there is only one event in the current month calendar.

    With the shortcode I made, using the ‘Skin’ option ‘Calendar/Monthly View’, and with the ‘Style’ set to ‘Simple’, the tooltip pop-up doesn’t work if there is only one entry or event for the month.

    https://postimg.cc/2Vwp7QCC

    If changing to the next month, then back again to the current month, the pop-up works on the single event.

    If there are 2 events or entries in the calendar for the current month, the pop-works.

    https://postimg.cc/MX1XxFmt

    2. The second issue is quite minor, and is to do with the strange comma and 3 dots.

    https://postimg.cc/zLnGCdX0

    I have explained all of this in my previous post.

    These ‘issues’ happen on all websites that I’ve tested on, and on my localhost/WAMP server that I use for development. It makes no difference which themes are used or whether there are any plugins enabled or disabled, or which theme is used.

    On my WAMP server, I have just installed a clean install of the current version of WordPress, with a new database, with no plugins installed, using the default WordPress ‘Twenty Twenty-One’ theme, and still have exactly the same issues.

    Regards.

    Plugin Author Webnus

    (@webnus)

    Hello @joelogic,

    We have not received any similar reports so far.
    Would you please install it on the live server and send a live URL?

    Best Regards,

    Thread Starter Joe B

    (@joelogic)

    Hi

    I will send you a link to your email, support@webnus.net

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.