Support » Fixing WordPress » Bug with the WordPress Visual Editor

  • Hello,

    Since wordpress 3.1, I’ve had a bug with wordpress when editing existing posts.

    In Visual Editor mode (NOT code source, visual editing), if I use the control-Shift-A keyboard shortcut, it will show BOTH the normal visual editor hyperlink addition popup, AND the html link addition popup loaded when we’re in “code source mode”.

    I know this description sounds confusing but I’m lost for words, to be honest. So I captured it into a video, the last 15 seconds show the actual bug :

    I don’t think I made something special to cause this bug, no adding or removing an extension around the time the bug first happened, no hacking wordpress core files or template files…

    I reinstalled wordpress, that bore no changes.

    This is not a life or death issue, it’s no big deal, but well, a bug calls for a fix, by definition 🙂

    If someone has an idea about it, an idea of where I could search the cause of this bug, help/suggestions/recommendations are welcome, thank you ! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • What Theme are you using, and what Plugins do you have activated?

    My theme is a heavily customized andreas-08-3-columns-ver-05. Customized for its looks, its sidebar with my stuff, and additional strings of texts here and there. How to say it, no real “functions” or home-brewed stuff were added.

    Maybe something inside the theme became partly incompatible with the latest wordpress versions, this theme is really old. But I also love its wonderfully low server impact (something useful with huge traffic, I don’t want to move from shared hosting to a VPS or a dedi, it would be more expensive and terribly complicated).

    As for my plugins, there’s a handful. I quote the ones potentially interacting with post creation :
    – custom smilies
    – flattr
    – intense debate
    – shortcoder
    – wp-polls
    – wp-postratings
    – wp to twitter

    As I wrote, this is not a life or death issue, if you don’t find, don’t bother yourself too much about it 🙂

    I quote the ones potentially interacting with post creation

    Actually, what you need to look for are Plugins that enqueue scripts such as jQuery (and check your Theme’s handling of script enqueueing, also).

    Thanks once again for the reply !

    (my reply is one mile long, I didn’t really know what parts to cut to make it shorter, sorry !)

    I had not a single clue about script enqueueing when I read your reply (no idea of its existence, nor of the way it worked), I learned from this page, I hope it’s the proper reference in the present case :

    Following the given information, it allowed me to check there was no mention of wp_enqueue_script in my template’s files.
    But if a script is enqueued in another way, I have no idea.

    (But why mentioning my theme, after all, we’re in the admin, aren’t we ? Or does my theme’s functions.php also affect what’s happening admin-side ?!?)


    Now, as for the plugins, there are 20 of them, these plugins are : Add Browser Search, Antispam Bee, Custom Smilies, Exploit Scanner, Flattr, Google XML Sitemaps, IntenseDebate, Less, Ozh’ Better Feed, Post Plugin Library, Random Posts, Search Suggest, Shortcoder, User Locker, WP-DBmanager, WP-PageNavi, WP-Polls (that one is deactivated), WP-PostRatings, WP Super Cache, and WP to Twitter.

    Inside these plugins code (thanks to Notepad++ !), I searched for wp_enqueue_script , but I don’t know if I should have searched for something else.

    The results didn’t bring me enlightenment, though. Just in case, I deactivated Shortcoder (a doubt), it didn’t change anything.

    F:\asupprimer\plugins\akismet\admin.php (1 hits)
    	Line 31: 	wp_enqueue_script('akismet.js');
      F:\asupprimer\plugins\antispam-bee\antispam_bee.php (3 hits)
    	Line 329: wp_enqueue_script('ab_script');
    	Line 462: wp_enqueue_script('google_jsapi');
    	Line 463: wp_enqueue_script('ab_chart');
      F:\asupprimer\plugins\flattr\flattr5.php (1 hits)
    	Line 49: 		wp_enqueue_script('flattrscript', ( isset($_SERVER['HTTPS']) && $_SERVER['HTTPS'] ? 'https://' : 'http://' ) . self::API_SCRIPT, array(), '0.6', true);
      F:\asupprimer\plugins\shortcoder\shortcoder.php (3 hits)
    	Line 59: 		wp_enqueue_script('jquery');
    	Line 60: 		wp_enqueue_script('shortcoder-admin-js', $sc_pluginpath . 'sc-admin-js.js', array('jquery'));
    	Line 61: 		wp_enqueue_script('aw-quick-tag-js', $sc_pluginpath . 'aw-quick-tags/awQuickTag.js', array('jquery', 'shortcoder-admin-js'));
      F:\asupprimer\plugins\wp-pagenavi\scb\BoxesPage.php (3 hits)
    	Line 175: 		wp_enqueue_script( 'common' );
    	Line 176: 		wp_enqueue_script( 'wp-lists' );
    	Line 177: 		wp_enqueue_script( 'postbox' );
      F:\asupprimer\plugins\wp-polls\wp-polls.php (3 hits)
    	Line 207: add_action('wp_enqueue_scripts', 'poll_scripts');
    	Line 224: 	wp_enqueue_script('wp-polls', plugins_url('wp-polls/polls-js.js'), array('jquery'), '2.50', true);
    	Line 243: 		wp_enqueue_script('wp-polls-admin', plugins_url('wp-polls/polls-admin-js.js'), array('jquery'), '2.50', true);
      F:\asupprimer\plugins\wp-postratings\wp-postratings.php (3 hits)
    	Line 128: add_action('wp_enqueue_scripts', 'ratings_scripts');
    	Line 154: 	wp_enqueue_script('wp-postratings', plugins_url('wp-postratings/postratings-js.js'), array('jquery'), '1.50', true);
    	Line 176: 		wp_enqueue_script('wp-postratings-admin', plugins_url('wp-postratings/postratings-admin-js.js'), array('jquery'), '1.50', true)


    I tried another approach, placed myself in a situation where the bug happened : creating a post, saving, coming back to edit it, and having the two hyperlink addition windows.
    Then I opened my page’s source code, and searched for <script type='text/javascript' src=' occurences.
    But there was nothing being called twice under small variations, from the looks of it :

    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=',utils&ver=fb5c271ac01e8186b23ece33d5ce4961'></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=',common,jquery-color,schedule,wp-ajax-response,autosave,wp-lists,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-query,admin-comments,suggest,jquery-ui-sortable,postbox,post,thickbox,media-upload&ver=2b90289b41abe121b9400cf60c21cac7'></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>
    <script type='text/javascript' src=''></script>

    And here… Well, same as before, I’m lost, and I don’t even know what to look for, or how…

    Once again, thank you if you can be of help, I hope I’m not abusing your time 🙂

    For me it was simply a broken file. Re-uploaded wp-includes and this fixed it (undoubtedly it was one or more files in the js/tinymce folder)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bug with the WordPress Visual Editor’ is closed to new replies.