Support » Plugin: Recent Posts FlexSlider » bug with our site

Viewing 10 replies - 1 through 10 (of 10 total)
  • hi, do you have any news?

    thank you very much
    Angelo

    Plugin Author David Wolfpaw

    (@davidjlaietta)

    Hi Angelo, the reason for that kind of conflict is if the same slider is loaded on a page in multiple places, as it would be with this plugin and the big slider. I have it setup to allow multiple sliders on the same page, but it won’t always work with sliders from another plugin/theme loading.

    Can you send a link to the site that it’s on for me to see how it’s running?

    HI David, thank you for the response.

    the site is https://www.rtvalhaurinelgrande.com/
    and the theme is https://themeforest.net/item/smartmag-responsive-retina-wordpress-magazine/6652608

    thank you very much
    Angelo

    Plugin Author David Wolfpaw

    (@davidjlaietta)

    Hi Angelo, thanks for confirming. The issue is what I figured: both sliders use the same script. There are a few ways to fix this, but they’d all involve some custom code on your site. Either disabling one of the scripts, or renaming one of them to have it load the other script.

    This could be done a few ways, but one that I can suggest is editing the plugin to remove the line add_action( 'wp_enqueue_scripts', array( $this, 'register_recent_posts_flexslider_scripts' ) ); in the plugin file recent-posts-flexslider.php, which is line 61.

    This isn’t the best way to do this, but it’s the easiest that I can recommend without changing up the theme or something else on your site.

    is there a way i can do it by editing the fucntion.php of the theme? because if i modify the plugin in the next update i will lose the changes no?

    Or you can put a config in the plugin that change the behaviour?

    thank you VERY much for you help
    Angelo

    Plugin Author David Wolfpaw

    (@davidjlaietta)

    This will remove the scripts on the plugin, but keep the styling that comes with it.

    add_action( ‘widgets_init’, ‘obm_remove_rpf_scripts’ );
    function obm_remove_rpf_scripts() {

    if ( class_exists( ‘Recent_Posts_FlexSlider’ ) ) {
    global $wp_widget_factory;
    remove_action( ‘wp_enqueue_scripts’, array( $wp_widget_factory->widgets[‘Recent_Posts_FlexSlider’], ‘register_recent_posts_flexslider_scripts’ ) );
    }

    }

    • This reply was modified 1 year, 8 months ago by  David Wolfpaw.

    Thank you David, i put the code in my function.php but is not working, when i enable the plugin the mail slider don’t work…

    How we can fix it?

    Thank you very much
    Angelo

    Plugin Author David Wolfpaw

    (@davidjlaietta)

    This is outside of the scope of what I can recommend here. The plugin is fairly limited in scope to allow it to be moved around or styled to match themes, but it won’t work in every case. This is something where a developer with access to your site would be able to solve the problem, but I can’t test the fix directly on your site to see if it interferes with anything else.

    hi, can you suggest in which way a developer can fix that? i think i have sufficient knowledgment to touch where is needed or you think the first snippet you put is the secure way to fix the problem?

    thank you very much for you time!!!
    Angelo

    Plugin Author David Wolfpaw

    (@davidjlaietta)

    They will need to examine any errors that come up in the Javascript console, or see if they can find another way to load the script for one slider without the other.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘bug with our site’ is closed to new replies.