Support » Plugin: Meow Lightbox » Bug with Divi in the admin

  • Resolved laugau

    (@laugau)


    Hello Jordy ;

    I had the chance to test your plugin on a client’s website based on Divi…
    Their gallery module is a crap, and I wanted to use the native WordPress Gallery system instead. But I needed a simple lightbox system to be able to enlarge and swipe between the images. Your plugin does perfectly that BUT…

    Then there is an incompatibility between Divi and your plugin that makes every edit impossible. A solution I found was to block your script in the backend :
    /wp-content/plugins/meow-lightbox/js/mwl-build.js?ver=2.0.5

    For the one who want to solve this simply copy/paste that in “Code Snippets” :

    function laugau_dequeue_script() 
    {
        // Run the dequeue script with the handle of the JavaScript file
        wp_dequeue_script( 'mwl-build-js' );
    	
    	// We could have also dequeue styles with the handle of the CSS file
        //wp_dequeue_style( $handle );
    
    }
    add_action( 'wp_enqueue_scripts', 'laugau_dequeue_script', 100 );

    Then don’t forget to activate the snippet “only on admin”.
    I hope that can help some.

    And of course thanks a lot for your plugin ! 🙂

    • This topic was modified 8 months, 2 weeks ago by laugau.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jordy Meow

    (@tigroumeow)

    Hello,

    Thanks a lot for this quick fix/workaround 🙂 I will test a bit more with Divi, and in fact, I heard of a similar issue with another pagebuilder. So I will work on a solution that definitely fixes this forever 😉 You can expect this fix for the next version.

    Thank you for posting this.

    I commented months ago there was a problem with the plugin when using with a Divi built site (my workaround has been to deactivate the Lightbox plugin when I need to edit), but I was not taken seriously and ignored.

    https://wordpress.org/support/topic/lightbox-not-working-with-divi/

    • This reply was modified 8 months, 1 week ago by topanga.
    • This reply was modified 8 months, 1 week ago by topanga.
    Plugin Author Jordy Meow

    (@tigroumeow)

    Don’t worry @scion529, I haven’t ignored, I know there is an issue but it’s a bit more general. That’s said, I am on it 🙂

    Okay Jordy, but it has been over three months since I reported it. A real PIA to deactivate a plugin everytime an edit is needed if you are a website builder.

    Can you tell me where I should place the above code so I can see how it works? Thank you in advance.

    Plugin Author Jordy Meow

    (@tigroumeow)

    In fact, which versions of Divi are you using? I still can’t reproduce the issue at all.

    The Meow Lightbox is not loaded in the WordPress Admin. However, the Divi Builder, in Front Editor mode, does behave like it’s not “in the admin”, so basically all the plugins are getting loaded normally.

    I am not sure why it wouldn’t work though.

    Do you have any messages in the Console Developer Tools?

    Using the most current Divi 4.4.8.

    It happens when you try to edit a page in the back end, not on the front end.
    See the screenshot below. Open a page in the admin side and try to edit it. The page has to be built on Divi. When you click on the gear, nothing happens.

    Page in Divi Builder to Edit

    • This reply was modified 8 months, 1 week ago by topanga.
    • This reply was modified 8 months, 1 week ago by topanga.
    Plugin Author Jordy Meow

    (@tigroumeow)

    Hello guys,

    I was not using this version of DIVI, that is why. They changed the way it works, and I had to find a way to detect that the builder was enabled on a “live page”.

    Anyway, that’s fixed, and I released a new version 🙂 Should be good.

    Thank you Jody. All of the sites I work on with DIVI + Meow Lightbox are working together as they should. I appreciate your hard work on this great plugin!

    • This reply was modified 8 months, 1 week ago by topanga.
    Plugin Author Jordy Meow

    (@tigroumeow)

    Super, I am glad it works @scion529! And I am so sorry for the time it took.

    Thread Starter laugau

    (@laugau)

    Congrats and thanks for the update Jordy 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Bug with Divi in the admin’ is closed to new replies.