Support » Plugin: Booster for WooCommerce » Bug with datepicker in Checkout Custom Fields Module

  • Using Checkout Custom Fields Module (Booster Plus):

    setting Datepicker/Weekpicker > Year Selector > Year Range is ignored.

    For ex. entering 1900:2001 (back-end screenshot) will result in an empty year dropdown (front-end screenshot).

    Trying with c-10:c+10 or -10:+10 will result in year dropdown containing only 2016, 2017, 2018.

    Already reported to support team support@booster.io with request #7404 a month ago, without any reply.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Algoritmika Ltd

    (@algoritmika)

    Hi @marcomarsala,

    Sorry for not replying earlier. It is probably my fault that I didn’t explain it clearly in documentation (will try to fix that), but in addition to setting Datepicker/Weekpicker: Year Selector: Year Range option, you also need to make sure that Datepicker/Weekpicker: Min Date and Datepicker/Weekpicker: Max Date options allow years to appear. As by default Datepicker/Weekpicker: Min Date is set to -365 days and Datepicker/Weekpicker: Max Date to 365, years are limited to -1 and +1 year, so when for example you set c-10:c+10, you can see 3 years only (that is, current year -1 and current year +1). So please try setting Datepicker/Weekpicker: Min Date to some large number like -36500 and Datepicker/Weekpicker: Max Date to 36500 (i.e. 100 years).

    Again, sorry for the delay.

    Best regards,
    Tom

Viewing 1 replies (of 1 total)
  • The topic ‘Bug with datepicker in Checkout Custom Fields Module’ is closed to new replies.