• Resolved 121940kz

    (@121940kz)


    Hello, i read through your release notes and found in version 2.3 there is a comment for “Improvement: Better detection of offloaded media URLs during page display”. I think there is a bug with this.

    When i enter my custom cdn name cdn.example.com my images no longer display on the front end. This is because the url’s instead of having /wp-content/uploads/ in the url (which is part of my s3 bucket) it somehow puts /storage/

    I do not know where this wording comes from but it is seemingly dynamically put there by presumably the detection on page display that you have implemented.

    If i put the CDN cname to my cloudfront distribution URL (so now it has nothing to do with my domain name) then the images work and are served correctly with /wp-content/uploads in the url name of cloudfront url on the front end.

    So, there is a bug or something where when using a cdn cname based on your own domain (cdn.mydomain.com) it puts /storage/ in the url on the front end. The media links in the back end are correct in the media library, so again this is just on front page display.

    • This topic was modified 2 months, 2 weeks ago by 121940kz.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor ianmjones

    (@ianmjones)

    Never heard of this one before.

    Please check that your web server or plugins don’t have any URL rewriting in effect that might be swapping out your chosen custom domain with a redirected version.

    121940kz

    (@121940kz)

    I will double check but I don’t recall anything. I am running on a multisite as well in case that would make a difference.

    121940kz

    (@121940kz)

    I just wanted to follow back up on this, in case anyone in the future ever stumbled upon this. It turns out, that the plugin “Hide My WP Ghost” adds rewrite rules in the .htaccess file. So after trying to fiddle around with that, and then reading that every time you save settings in Hide My WP Ghost it will put their values back, I decided instead to set my S3 path for Offload S3 to match what the re-write rule is doing.

    So basically i’m letting Offload S3 and Hide My WP Ghost play together now by having them both follow the same path which was /storage instead of /wp-content/uploads

    Anyway, hope this is helpful to someone in the future wondering why a cdn cname gets overwritten

    Plugin Contributor ianmjones

    (@ianmjones)

    Thanks for the info @121940kz, much appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.