Support » Plugin: PopBox For Elementor » Bug with a moving button and extra gap

  • Resolved jdimina

    (@jdimina)


    After the update a bug appeared.
    When you click on the button, it moves to the left and adds a gap on the right side of the screen. This happens on all my sites.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author NoreWP

    (@norewp)

    Thank you for the report and the link @jdimina

    Investigating and will get a fix out as soon as possible.

    Plugin Author NoreWP

    (@norewp)

    I’ve done a thorough investigation and unfortunately this issue is theme related.

    I’ve tested with the default theme TwentySeventeen, GeneratePress, Hestia, Astra, OceanWP and 3 of my own themes – the issue only appears on Astra & OceanWP.

    Both themes have the html property declared as overflow: scroll in their stylesheet like so html{overflow-y:scroll}

    I’ll be putting out a workaround fix once I’ve finished investigating the other issue, but it would be better if those themes addressed the issue with their files.

    Thread Starter jdimina

    (@jdimina)

    Hello! Thanks for the quick response! Tell me, please, what should I write in the code? I wrote
    <style>
    html{overflow-y:auto;}
    </style>
    but it does not work.
    When I write
    <style>
    html{overflow-y:hidden;}
    </style>
    the scroll disappears completely.

    Plugin Author NoreWP

    (@norewp)

    There is no easier solution outside of the theme.

    Here’s the workaround I came up with – the background does not scroll when the modal is open, this rule is a Bootstrap built in.

    html {
    	-ms-overflow-style: scrollbar;
    	overflow: hidden;
    	height: 100%;
    }
    body {
    	overflow: auto;
    	height: 100%;
    }

    I’ll be including this in the plugin when I push the next update.

    Thread Starter jdimina

    (@jdimina)

    Man, you’re incredibly cool! Everything works as it should! Thank you)

    Plugin Author NoreWP

    (@norewp)

    You are most welcome and happy to be of service 🙂

    Closing this as resolved for now but feel free to open a new thread if you encounter any other issues.

    Regards,
    Zulf

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Bug with a moving button and extra gap’ is closed to new replies.