WordPress.org

Support

Support » Plugins and Hacks » Admin Menu Editor » Bug when saving settings

Bug when saving settings

  • When I go to Settings -> Menu Editor -> Settings and click on the save settings button, it takes me to the login screen (even though I was already logged in without time-out). After logging in again, it takes me to a plain version of the settings page again (i.e. without the admin bar, admin menu etc) and the changed options have not been saved.
    If I then change the options again and click on the save settings button, the settings *are* saved and I’m taken back to a normal version of the settings page.

    Tried several times with same result, though I have to admit this is on a WP 3.4.2 install which I’m in the process of upgrading.

    http://wordpress.org/plugins/admin-menu-editor/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Janis Elsts

    @whiteshadow

    Sorry, I’m afraid I haven’t heard of anyone encountering this kind of a problem before. Have you noticed any correlations between the settings you change and getting logged out, or does it seem to happen every time, regardless of what changes you’ve made?

    Just in case it’s a plugin conflict, try temporarily deactivating other plugins before saving the menu. If it works, re-activate your plugins one by one until it stops working again to identify the conflict.

    Actually, the bug is a lot more far-reaching than I thought. It makes me re-login for *every* single admin page…. no matter which page, no matter the action (i.e. no matter whether I just click on an admin menu link or try to save settings).

    It only started after upgrading AME and de-activating AME solves it.

    The PHP error log does not show any related errors, so I’d have to dive in to figure out what is going on. Unfortunately I don’t have the time at the moment…

    Plugin Author Janis Elsts

    @whiteshadow

    If it’s really related to the latest update, you might be able to work around it by downgrading to the previous version (at least for now). You can download older versions of the plugin here.

    I’ve deactivated the plugin for now as I want to finish the upgrade process first. Will test again after that and if I find the time, will see if I can find the error and fix it for you.

    Will keep you informed.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Bug when saving settings’ is closed to new replies.
Skip to toolbar