Support » Plugin: Duplicate Post » Bug when cloning on the original permalink

  • here’s what i try since some update in the past (latest version installed, in older versions, this was not the case)
    – clone a page (pagename “title”, permalink “title”)
    – the clone gets a “draft”
    – the draft also and automatically gets the pagename “title” and the permalink “title-2”. exactly like the original (BAD!)
    – do not rename or edit the draft
    – when editing the original page, the permalink changes to title-2 (because the same title exits twice (draft and original) (very bad. the permalink MUST be the same and must not change)

    this can be a huge legal issue if you clone a page for backup and go on and edit the original page which then gets the wrong permalink on saving. (e.g. on an imprimt page).

    solution:
    in older versions the draft automatically got a pagename like “title (copy)” and the permalink was empty. this should be the same now!

    best regards

Viewing 6 replies - 1 through 6 (of 6 total)
  • I also had this problem – I have 2 sites, one is WP 4.9.4, plugin version 3.2.1 – the latest versions and am finding that when I save a draft from a template created with the Duplicate Post plugin it doesn’t change the title.

    The other site is still running WP v4.7.9 and plugin v 3.1.2 and is operating fine as it always has. So I’m not sure if it’s really WP or the plugin that is causing the problem but looks like the 2 most recent versions aren’t compatible, so hopefully this info will help.

    Plugin Author Lopo

    (@lopo)

    Hi @throotsdev and @smchugh,

    can you check under SettingsDuplicate Post, tab What to copy, if the checkbox for Slug is enabled?
    If yes, can you uncheck it, save the options and then try again if the issue still occur?

    Let me know, thanks for the help

    @lopo thanks for the quick answer.
    that did it!

    @lopo I actually tried this – honest – and it seems to have sorted the problem – thanks!
    However, I *think* I may have another problem where it copies across the ‘Private’ status and the original publication date. There’s no similar way I can see to stop these coming across via the checkboxes. But I need to test some more and will keep you informed (I’m just looking at posts I set live and I haven’t got that many to do)

    The old way it worked in 3.1.2 was fine…. took me a while to notice what the new version was doing and it has made quite a mess on my site… many hours to sort out.

    Can you not update the plugin so that slut is not selected by default… that might help others..

    I am having a similar problem. I tried moving a page from sub page to no parent and it is adding that -2. I do not have slugs checked. I don’t even recall making a duplicate page and there are none even in my trash but it is holding on to some permalinks. I also went to settings and changed the permalink options, saved, then changed back to custom but that did not help.
    Love your plugin btw.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Bug when cloning on the original permalink’ is closed to new replies.