Support » Plugin: G-Forms hCaptcha » Bug: Two forms on same page using Invisible mode breaks form output

  • Resolved KZeni

    (@kzeni)


    I have a contact form in the footer of my site that uses invisible hCaptcha via this plugin while also having another page where there’s an in-page contact form that also uses invisible hCaptcha. However, I found this actually prevented one of the forms from displaying properly (it seems to be left as display:none; which I’ve read means it failed conditional logic check [even though the form is straightforward… so it might just be some other JS related error causing this in general.])

    One example I have is https://www.raceforthespacecr.org/application/ where the main form on the page would never output if both that & the form in the footer were both using the invisible display mode via this plugin.

    As an aside, it appears to not break when one/both of them were using the checkbox mode. However, I’d like to avoid the checkbox field showing for design purposes (and I’d imagine this should be possible.)

    I’ve switched over to Gravity Forms’ built-in reCAPTCHA for invisible captcha on both forms and it’s working perfectly fine. I would like to be able to switch back to using this plugin and/or use it for future sites that have this scenario come up & have it without issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Kevin

    (@webandappeasy)

    Thank you for reporting.

    Have you tried to enable reCAPTCHA compatibility under the fields ‘advanced’ tab?
    I’ve also had this before on one of our own websites, and implemented this option to prevent that the other hCaptcha failed.

    Thread Starter KZeni

    (@kzeni)

    I saw that was a potential fix elsewhere so I did try it with both having that setting turned off, both turned on, and each form using different settings… it didn’t appear to fix the issue in any of those scenarios, unfortunately.

    Plugin Author Kevin

    (@webandappeasy)

    A heads up on this thread. I’ve solved the problem and the fix is implemented in the next update that is almost ready to go live.

    Thread Starter KZeni

    (@kzeni)

    Great to hear & thanks for the update!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.