WordPress.org

Forums

Paid Memberships Pro
[resolved] BUG -stylesheet not loading in all browsers (3 posts)

  1. Lisa
    Member
    Posted 2 years ago #

    In plugin version 1.5.9 the stylesheet is not loading on the checkout page, causing problems with checkout.

    I was alerted to this by 2 customers. Problem only seems to happen in Google Chrome, and in Internet Explorer (customer does not know which version and sent screenshot displaying the same)

    In Safari and on Safari for iPad is working fine.

    I observe problem on Chrome for Mac 24.0.1312.57 on 2 machines.

    Also, customer account info should really come after credit card info, customers don't understand.

    See these screenshots for details - https://www.dropbox.com/sh/d9tpdwpw7wjxl9e/PG27B-wsZl

    http://wordpress.org/extend/plugins/paid-memberships-pro/

  2. Jason Coleman
    Member
    Plugin Author

    Posted 2 years ago #

    You followed up by email, and I think you figured this out.

    Might have been related to loading css assets over HTTP on an HTTPS page... which might happen if your theme doesn't enqueue scripts in the proper "WordPress way". The "nuclear option" in the PMPro settings page might help.

    It also might be a caching issue. In general, you don't want to cache the membership pages, checkout pages, or any page that shows up different for different members.

  3. Lisa
    Member
    Posted 2 years ago #

    Thank you Jason for your outstanding support.

    I'm going to have to change hosts to control the caching - it's either all or nothing with mine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Paid Memberships Pro
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic