Bug: Single quote marks (') being replaced by doubles (") (3 posts)

  1. pauliewaulie
    Posted 6 years ago #

    A really odd one. Just installed wordpress using installatron. But whenever I type anything into the site (apart from into the html editor, which works fine) with a single >>> ' <<< mark, it doubles it up. It doesn't replace it with a double quote mark - i.e. the >>> " <<< character that you get if you hold down the shift key and hit the >>> ' <<< key, but it adds a second >>> ' <<< mark - looking like this: ''

    I'm 99% certain that this isn't just a problem that comes from the theme as I'm getting the same problem with a few of them.

    My site is at http://www.publicservicebroadcasting.org.uk have a look. Any suggestions gratefully received!

  2. pauliewaulie
    Posted 6 years ago #

    I've just revisited it, and it *is* effecting the html editor as well - but bizarrely, not uniformly. Some single quote marks stay single, but when I typed the word 'it's' it gradually morphed into it””””””””””””””””s as I saved and resaved the page. It also seems to be doubling them up into " marks now! I've not found anything in the forums and I'm completely stumped by this one.

    I do know that databases sometimes take steps to avoid people putting ' marks in - but that's the limit of my knowledge on this. Any ideas?

  3. smachalk
    Posted 5 years ago #

    I found this elsewhere after much searching and it worked for me also.

    Found Here:

    You can also add this to your .htaccess file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    php_value magic_quotes_gpc 0
    php_flag magic_quotes_runtime 0
    # END WordPress

    This worked for me!

Topic Closed

This topic has been closed to new replies.

About this Topic