Support » Theme: Hueman » Bug since Version: 3.4.20: white space after header image

  • Resolved webbeetle

    (@webbeetle)


    Since the latest version update my site has too much white space below the header image! It happens with every post page, not only the front page.

    You can see a screen capture (with ‘Inspect Element’ turned on) here:
    https://i.postimg.cc/dQ2V2BzV/faulty-header-space-HUEMAN.jpg

    In the code it says something like ‘fixed header on’ – which of course won’t be responsive… Where is this bloody code hiding??

    Worse still: it seems to maintain the same height on mobile screens – so the top two-thirds of the screen is blank!
    .
    .
    .
    ———————————
    General observation:
    recent updates for Hueman have come down in quality, drastically. After the second last update I had trouble with the ::before and ::after definitions in width. Suddenly every page displayed a blank sidebar, even when set to ‘no sidebar’, thus covering the right side of all page content.
    And with several updates before I had trouble too! New class for the mobile menu, suddenly I had white text on my beige background, my custom css wasn’t acknowledged anymore. Then the arrows for the mobile menu expand wouldn’t work for some time, and so on… I’m wasting so much time on fixing update problems that I’m hesitant to do these. And there’s certainly no, really NO, incentive to go for the Pro version – when the free version is causing so many problems! Sorry for the rant, but I had pressing other things to catch up with – none of which I have got to so far.

    • This topic was modified 6 months, 3 weeks ago by webbeetle.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @webbeetle,
    thanks for reporting this.
    I’m not able to reproduce the issue on my test environment.

    Can you please make sure you’ve followed the troubleshooting steps here?
    https://wordpress.org/support/topic/please-read-before-posting-75/

    Especially the point 3.

    Please feel free to open a new ticket for any issues you encountered.
    Latest versions, as usual, have been tested before being released, though if you’re using custom css in a child-theme you might need to make some changes to adapt it.

    I don’t understand how you can say you cannot “reproduce the issue”!

    I’ve cleared the cache (WP Rocket) on the server and in my browsers. The problem persists!
    I then run a few speed tests on https://tools.pingdom.com/, which automatically creates a preview thumbnail (so there shouldn’t be any browser cache involved, I tested the blog post for the first time) – these screen previews from pingdom show clearly the gap of white space (beige in my case = background color). So how can you say that you cannot “reproduce the issue on my test environment.” Are you being paid per ticket you close?

    Please see screen captures (pingdom and mobile) from today – after your reply and after clearing caches (Especially the point 3.):

    https://i.postimg.cc/Hk8FVq4z/Empty-space-today-on-dare2go.jpg

    Hi there,
    thanks for the further info on the issue.

    With

    Iโ€™m not able to reproduce the issue on my test environment.

    I mean that I’m not able to reproduce the issue on a test website I’ve set up. I can see the issue on your website though, that’s why I’ve asked you to follow troubleshooting steps which include server side settings change. If I thought your website was not showing any issue I wouldn’t suggested to clear the server side cache or to disable your plugins. ๐Ÿ˜€

    About clearing the cache: The 3rd troubleshooting step reads:

    Cache plugin : if you are using a server cache or cache plugin, please clear itโ€™s cache content and disable caching via itโ€™s settings.

    you say:

    Iโ€™ve cleared the cache (WP Rocket) on the server and in my browsers. The problem persists!

    Did you also disable the caching?

    Also, step 6th:

    Check for plugin conflict : deactivate all of your plugins. If it fixes the issue, re-activate your plugins one by one, until you identify the plugin in conflict.

    Did you disable your plugins to see whether one of them is the cause of the issue?

    For example: the issue on your site might happen if the header image is “lazyloaded”. I can see this on your site (that’s your header image):
    https://imgur.com/TPjEgXh

    Which makes me guess “something” (a plugin?) on your site is performing the images lazy loading.

    About:

    Are you being paid per ticket you close?

    No I’m not. Also I didn’t close any ticket, this ticket is open. What are you talking about? I wouldn’t even have the capabilities to do that. Why do you say that?
    As you can see I’m trying to do my best to help you with this issue.

    Sorry, Rocco!
    I got the wrong impression (paid per ticket) from the one sentence “Please feel free to open a new ticket for any issues you encountered.” I apologise!

    And you were right: it is being caused by lazy image loading!
    Don’t ask me why. I will open a ticket with WP Rocket for this.

    Again, sorry for having been so impatient, but we never find time to write content. Yesterday and today were 2 free days to write a new post (so I thought) – instead I have been only battling problems (like this). Not a single line of content written! :p

    No problem, glad you solved ๐Ÿ˜€

    The issue is not a WP Rocket bug though, nor a theme bug, it’s just that the header image lazy load “hurts” the theme sticky header feature…
    If you could exclude an image from being lazyloaded based on the image CSS class maybe…

    Cheers ๐Ÿ˜‰

    Rocco

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bug since Version: 3.4.20: white space after header image’ is closed to new replies.