Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Bug Report: Visual Editor require “Featured Image”

  • Hello,

    First thanks for the nice plugin!

    I was using it on a custom (very basic, minimal code) theme and the “Add / Edit Photonic Gallery” would not completely work.
    Switching back to TwentySeventeen make it work again.

    With the custom theme I was getting the following js error:
    TypeError: wp.media.view.settings.post is undefined (media-audiovideo.js:84)

    I found that the js loaded by wp was in a different order when it didn’t work.

    finally, adding “add_theme_support( ‘post-thumbnails’ );” in my theme init function is fixing it !!

    So I guess that you are missing a dependency somewhere to be able to enable Photonic without adding “Featured Image” support in the theme.

    Is it a known issue ?

    Best Regards and again thanks for the nice Plugin !

Viewing 1 replies (of 1 total)
  • Plugin Author Sayontan Sinha

    (@sayontan)

    Thanks! This is an interesting pointer.

    Note that the Visual Editor not working in some cases is a documented issue (see the second question in the FAQ). I don’t think that the add_theme_support('post-thumbnails') fixes this across the board, but I wasn’t aware that it was one of the ways to fix it for some special cases. The reason I say that the fix doesn’t work for all cases is because I have been able to replicate this issue with TwentySixteen and certain other activated plugins.

    The problem occurs in conflict with some specific scenarios, and since it is not possible for me to guess how but there are a couple of ways to work around it:

    1. Do you have any other plugin that introduces a custom post type? Are you trying to edit a post of that post type? You can verify this by going to Photonic → Settings → Generic Options → Generic Settings → Disable Visual Editing for specific post types. Out of the box WP has just “Posts”, “Pages” and “Media” as the defined types. If you are seeing others, and if editing those is causing an issue, using this option try disabling the visual editor for those post types.
    2. If the above is not true, or if applying it to the conflicting post-type is not fixing the issue, use the “thermonuclear” option, and disable Photonic for the Visual Editor completely via Photonic → Settings → Generic Options → Generic Settings → Disable shortcode editing in Visual Editor. If you disable the editor in this manner, you will see a “No items found” gallery in the visual editor, but if you switch to the Text Editor, you can select the shortcode and click on “Add / Edit Photonic Gallery” – that will let you use the interactive workflow.
Viewing 1 replies (of 1 total)
  • The topic ‘Bug Report: Visual Editor require “Featured Image”’ is closed to new replies.