Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Bug Report: SVG’s have identical ID’s.

  • Resolved David Bee

    (@davidbawiec)


    Hi!

    Back here with another small bug report along with a suggested fix! ๐Ÿ™‚

    So when selecting from the different Gutenberg blocks, Give uses an SVG to render the Give icon. However, it uses the following clip-path clipPath="url(#SVGID_2_)". Which would work like a charm if there was only one #SVGID_2_. Unfortunately, since GiveWP creates 5 different blocks, and each block defines it’s own set of #SVGID_1_ and #SVGID_2_‘s, we end up with 5 of each. This is against ID usage standards, which results in it breaking the clipping and not rendering the icon in some browsers (for example in Firefox):

    To fix this, I’d suggest either making sure each SVG has a unique set of IDs, or replacing them with a class.

    Let me know your thoughts!
    David

    • This topic was modified 5 months, 3 weeks ago by David Bee.
    • This topic was modified 5 months, 3 weeks ago by David Bee.
    • This topic was modified 5 months, 3 weeks ago by David Bee.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Matheus Martins

    (@matheusfd)

    Hey @davidbawiec,

    Glad you reached out!

    Thanks for raising this issue! I’ve passed it to the development team so they can take a look at it and see how we can solve that – also, thanks for the solution idea.

    You can follow up on the progress of the fix here https://feedback.givewp.com/bug-reports/p/gutenberg-blocks-svgs-have-identical-ids

    Issues like this that are not preventing donations or have a simple workaround are generally prioritized at the end of an 8-week development cycle and then tested and released. That means it can be up to 10 weeks for issues like this to be resolved.

    Thanks for using GiveWP! Have a great day.

    Plugin Contributor Ben Meredith

    (@benmeredithgmailcom)

    Hey @davidbawiec,

    Following up here to let you know that this issue is resolved in GiveWP 2.16.0, released today! Thanks for reporting the issue, and let us know if we can help in any other way!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.