Support » Fixing WordPress » Bug report: Specific phrase impossible to save or publish

  • I wrote a text about advanced searching and filtering in Gmail two days ago, now at last published (in Swedish) at

    In my text I summarize Googles search options. WP kept saving drafts of my text while I was writing it, but when I was almost ready the autosaving hung. When I tried to publish I was sent to a public page on my blog stating that I was looking for something that could not be found. I tried over and over again, and have kept trying for two days now.

    My final approach was to keep my draft in a text editor, pasting the first paragraph into the WP editor (write post page), adding title, tags and categories once again, pressing Save and keep editing, and when this worked as expected repeating with one more paragraph.

    This way I was able to find the exact combination of characters that locked up the system, making it impossible to save or publish, and making WP hang when trying to autosave the draft. A post containing ‘bcc:’ will not save. Inserting <wbr></wbr> between all letters of the phrase finally solved the problem.

    I have no idea if the bug is in WP core or in some plugin I am using. I still run WP 2.3.1, would have upgraded if this bug had not kept me busy, the theme is a modified Genki theme.

    AddThis Social Bookmarking Widget (drop-down)
    Dagon Design Sitemap Generator
    Easy Gravatars
    Executable PHP widget
    Get Recent Comments
    Google Adsense widget
    Google Ad Wrap
    Google XML Sitemaps
    Related Posts
    Simple Tags (1.2.4 — other plugins are latest version)
    technorati Feed Widget
    Top Posts By Category Stats
    WordPress Database Backup
    WP-ContactForm: Akismet Edition (not working)

    I may not be reading responses to this, but bughunters are welcome to contact me if you need more details.

    Johan Adler
    Stockholm, Sweden

Viewing 6 replies - 1 through 6 (of 6 total)
  • whooami



    there’s a good chance that that that is either being blocked by a contact form, OR mod_security.

    blind cc’s are routinely used for spamming — and most decent contact form plugins block their usage. mod_security, as well, can be trivially set up to block them as well, however the resulting “error” would have been different.

    So thats not a bug except to say that you ought to be able to use the phrase within the context you have outlined.

    If I were you, and I were curious enough, I would be auditing any plugins that manage any kind of email functions, and looking for that phrase. I have 20 bucks that says its a plugin, especially since I cab plaster the word bcc all over my vanilla install of 2.3.2 and I cant reproduce your error.

    A quick look at the now deactivated WP-ContactForm: Akismet Edition that never worked for me anyway, shows that it will filter out the phrases to: and cc: but only in fields of the intended email it should send. No mention of bcc:.

    If the error is not in WP core it ought to be in a plugin that is filtering post text, not in a plugin of a more administrative kind. So the widget plugs, the microformat, backup etc should hopefully not be part of this. Seems silly too, barfing about a bcc: in the middle of a post, which is why I wanted to report it in the first place.




    sure, but my point is that youre reporting it to the wrong place 🙂 The author of that plugin is perhaps the one that needs to be made aware of the problem.

    As I stated, I can plaster the phrase bcc all over my install without any consequence, so if its NOT a plugin, than its a server-side issue — either way, its not something that being caused by WP. 🙂

    Are you using the exact phrase ‘bcc:’, all four characters? That’s the one that gave me trouble.

    Sure, if I knew which plugin it could be I would talk to the author personally, but this was a major problem for me for two days, and other people are likely to use the plugins I am using, so someone else could run into this too some day.

    A full search of the plugin directory shows that the only occurence of ‘bcc’ is a function call by the backup plugin.

    wp-db-backup.php calls $phpmailer->ClearBCCs()

    Searching all files in my public_html shows that wp-includes/pluggable.php makes the same call, and that wp-includes/class-phpmailer.php seems to be able to handle bcc:s, having a bunch of references to it. No other file mentions this.




    Are you using the exact phrase ‘bcc:’, all four characters? That’s the one that gave me trouble.

    yes, and I have no trouble on a vanilla install of WP 2.3.2.

    In fact, now I have three posts with different iterations of the phrase, complete with punctuation, and no troubles.

    I would share the blog url but its private, sorry.

    A post containing ‘bcc:’ will not save.

    and a comment?

    I trust you, no need for URL. You referred to ‘bcc’, just wanted to be sure you had tried ‘bcc:’.

    Have not tried it with comments.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Bug report: Specific phrase impossible to save or publish’ is closed to new replies.