Support » Plugin: Feed Them Social - for Twitter feed, Youtube and more » Bug Report: Latest version generates “undefined variable” errors in error log

  • Resolved WEBHAUS

    (@webhaus)


    Hello,

    Just wanted to report that I’m getting “PHP Notice: Undefined variable: fts_display_cache_time in /wp-content/plugins/feed-them-social/includes/feed-them-functions.php on line 2850” errors all the time, after I updated your plugin.

    After a little code inspection, I noticed, that in that particular piece of code you are using “switch” without a default fallback defined.

    Changed this:
    case '300':
    To this:
    default: case '300':

    And everything works great now. I guess you should add a default value for “Display Cache Time” if there isn’t any set.

    Regards,
    Edgars / WEBHAUS

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author slickremix

    (@slickremix)

    Hey @webhaus,
    Thanks for giving us a fix to this bug! We’ll be sure to get this implemented in the next update!

    Thanks again,
    Justin Labadie

    Plugin Author slickremix

    (@slickremix)

    This will be fixed in the 2.4.8 and should be pushed at some point today. Thanks for again for pointing this out.

    Spencer

    stalnz

    (@stalnz)

    Hello,

    I have the same problem i think, i don’t know how to get the tekst under the feed away.

    Notice: Undefined variable: FBpost_single_id in /customers/b/d/0/stalnoorderzon.nl/httpd.www/wp-content/plugins/feed-them-social/feeds/facebook/facebook-feed-post-types.php on line 163 Notice: Undefined variable: FBpost_single_id in /customers/b/d/0/stalnoorderzon.nl/httpd.www/wp-content/plugins/feed-them-social/feeds/facebook/facebook-feed-post-types.php on line 163 Notice: Undefined variable: FBpost_single_id in /customers/b/d/0/stalnoorderzon.nl/httpd.www/wp-content/plugins/feed-them-social/feeds/facebook/facebook-feed-post-types.php on line 163 Notice: Undefined variable: FBpost_single_id in /customers/b/d/0/stalnoorderzon.nl/httpd.www/wp-content/plugins/feed-them-social/feeds/facebook/facebook-feed-post-types.php on line 163

    It’s under the facebook photo feed. The facebook page feed is now oke had the same problem but whit checking something off it was away, but i can’t remember what it was and i don’t have the same options on the photo feed. I did try to clear chase, and something with the date’s but it’s still there. I don’t know what to do πŸ™

    Plugin Author slickremix

    (@slickremix)

    Hey @stalnz,
    I would be glad to help out, can you please include these 3 things?

    1. The shortcode you are trying to use.
    2. An example link to the problem in question.
    3. The report from the System Info page of our plugin. Click here if you are unsure how to do this. https://www.slickremix.com/docs/system-info-page/

    Thanks,
    Justin Labadie

    stalnz

    (@stalnz)

    [fts_facebook type=album_photos id=495421427183831 access_token= (i delete the token in for this post) posts=4 description=no album_id=photo_stream image_width=250px image_height=250px space_between_photos=1px hide_date_likes_comments=no center_container=yes]

    think you mean the websitelink http://www.stalnoorderzon.nl/ otherwise it’s in my first message.

    ### Begin System Info ###

    SITE_URL: http://www.stalnoorderzon.nl
    Feed Them Social Version: 2.5.0

    — WordPress Configuration:

    WordPress Version: 4.9.8
    Multisite: No
    Permalink Structure: /%postname%/
    Active Theme: evolve 3.5.0
    PHP Memory Limit: 512M
    WP_DEBUG: Enabled

    — Webserver Configuration:

    PHP Version: 5.6.36
    Web Server Info: Apache

    — PHP Configuration:

    Safe Mode: No
    Upload Max Size: 96M
    Post Max Size: 96M
    Upload Max Filesize: 96M
    Time Limit: 50
    Max Input Vars: 5000
    Allow URL File Open: On (1)
    Display Erros: On (1)

    — PHP Extensions:

    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.

    — FTS Settings->Global Options:

    Cache time: 1 Day (Default)

    — Active Plugins:

    Akismet Anti-Spam: 4.0.8
    Click to Chat for WhatsApp: 1.6
    Contact Form 7: 5.0.4
    Custom Facebook Feed: 2.7.2
    Feed Them Social (Facebook, Instagram, Twitter, etc): 2.5.0
    Formidable Forms: 3.03.01
    Jetpack by WordPress.com: 6.5
    Social Media and Share Icons (Ultimate Social Media): 2.0.4
    TablePress: 1.9.1
    Yoast SEO: 8.2

    — Custom Token or Keys added to Options Pages
    — You must have a custom token to use the feeds

    Facebook App Token: Yes
    FB App ID for Like Button: No
    Twitter Consumer Key: No
    Twitter Secret: No
    Twitter Token: No
    Twitter Token Secret: No
    Pinterest Token: No
    Instagram: Yes
    YouTube: Yes

    — FaceBook & Twitter Date Format and Timezone

    Date Format: one-day-ago
    Timezone: Europe/Amsterdam

    — Hide Facebook Images in Posts:

    Hide: No

    — Hide Facebook Error Handler:

    Hide: Yes

    — Fix Twitter Time:

    Fix: No

    — Disable Magnific CSS:

    Fix: No

    — Fix Internal Server Error:

    ### End System Info ###

    Plugin Author slickremix

    (@slickremix)

    Thanks for pointing that out, I’ll have that fixed in version 2.5.1.

    In the meantime if you are done developing your site and it is live to the public I would always suggest turning off wp_debug mode. This is only required to be set to true so you can view and debug warning like you are seeing. They are simple warning and should not cause any harm besides being annoying on the page πŸ™‚

    So to turn wp_debug off, go to your wp-config.php file in the root of your install and look for the option wp_debug and set it to false.

    Hope that helps and have a great rest of the weekend.

    Spencer

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Bug Report: Latest version generates “undefined variable” errors in error log’ is closed to new replies.