Support » Plugin: Easy Panorama » Bug report – “Add Panorama” Button

  • I found a small issue where the admin Add Panorama button has a span that stretches to cover other media buttons above the WYSIWIG Editor. I’ve tracked down the issue to the class-easy-panorama-admin.php.

    CURRENT CODE:

      public function addPanoramaButton() {
        echo '<span id="insert-panorama" class="button insert-panorama"><span class="dashicons dashicons-camera" style="color:#82878c; vertical-align:text-top;"></span> ' .  __('Add Panorama', $this->plugin_name) . '</a>';
      }
    

    SHOULD BE:

      public function addPanoramaButton() {
        echo '<a id="insert-panorama" class="button insert-panorama"><span class="dashicons dashicons-camera" style="color:#82878c; vertical-align:text-top;"></span> ' .  __('Add Panorama', $this->plugin_name) . '</a>';
      }
    
    • This topic was modified 2 years, 1 month ago by  icehouze.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Leonardo Giacone

    (@leopeo)

    Hello @icehouze,
    nice catch! I will release a new version soon and including also the fix to this bug.

    Could you please tell me which OS and browser are you using?

    Regards,
    Leonardo

    OS X El Capitan and I used the plugin in multiple browers (Firefox, Safari and Chrome). It’s working as expected after I modified the above line.

    Confirm this bug… On windows 10, multiple browsers…
    2 months is a long time for a big bug like this to exist?

    Are you still planning an update?

    thanks @icehouze for the solution!

    yes this bug still exists in all the browsers i’ve tested with on all platforms.

    even just a settings option to disable the editor button would be ok.

    hope you can fix it soon. 😉

    thanks

    Plugin Author Leonardo Giacone

    (@leopeo)

    Hi everyone,
    this bug has been fixed in version 1.0.2 🙂
    Could you please test it and let me know if it solves it?

    Thank you,
    Leonardo

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bug report – “Add Panorama” Button’ is closed to new replies.