Support » Plugin: All In One WP Security & Firewall » Bug Report:

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor mbrsolution


    Hi Handoko, I just carried out a test on one of my websites and it does work for me.

    You must have some conflict either with a plugin or the theme. Can you carry out some test by disabling all your plugins except this one and enable one by one to see if it is a plugin. If that does not work for you can you test one of WordPress default themes like Twenty Thirteen.

    Kind regards



    Thanks for your response.

    I’ve tried to disabled all plugins (except All In One WP Security & Firewall), I also tried to change the theme back to Twenty Fourteen. None of them cause the issue.

    I use this plugin in 3 websites, all of them have same issue.

    Is there any way I can contact you, to give you my login detail so you can inspect the problem and fix it?

    Plugin Contributor mbrsolution


    Hi Handoko I forgot to ask you. Have you tested this in other browsers? Which browser did you use when this issue occurred?

    Thank you



    My computer system:
    – Ubuntu 14.04 LTS 64-bit
    – Adobe Flash
    – OpenJDK Java runtime not installed

    Browsers I used:
    – SeaMonkey 2.26
    – Firefox 29.0
    – Opera 12.16 Build 1860 Linux x86_64

    I used 3 browsers above, all of them have the same issue. I can see some items listed in the 404 error logs. But if I clicked the the IP Address for sorting them, they will gone and become empty.

    Here are the information of one the website and its web server:
    – PHP Version: 5.5.13
    – PHP Memory Usage: 22.28 MB
    – PHP Memory Limit: 256M
    – PHP Safe Mode: Off
    – PHP Allow URL fopen: On
    – PHP Allow URL Include: Off
    – PHP Max Script Execution Time: 30 Seconds
    – WordPress Version: 3.9.1
    – WPMU: No
    – MySQL Version: 5.5.34
    – CURL Library Present: Yes

    Theme and plugins used:
    – Weaver II theme
    – All In One WP Security v3.7.5
    – ARYO Activity Log 2.1.2
    – Bad Behavior 2.2.15
    – Column Shortcodes 0.6.4
    – Fast Secure Contact Form 4.0.19
    – wp-jquery-lightbox 1.4.5

    I ever tried to switch to WordPress default themes, the issue still happened. So I don’t think theme is the cause of problem.

    Plugin Author wpsolutions


    Hi Handoko,
    I just want to confirm a few things:

    There were some 404 error items being listed in the table, but it showed nothing after I clicked the sort by IP Address

    Are you referring to the list of “404 Event Logs” in the “404 Detection” tab of the firewall menu?

    When you click on the “IP Address” column heading what do you mean when you say it showed nothing?

    That table should continue to list the 404 events but it should also show a little black triangle next to the “IP Address” name. Does this happen for you?



    Yes, after I click on the “IP Address” column heading, the list become empty. It said “No items found.“.

    I can see the the little black triangle on the column heading. If I click the column heading again, I can see the triangle being flipped upside down. But it still said “No items found.”

    The truth is there really had some items in the list.

    Below is a link to the screenshots:

    The first screenshot (top) was taken before I clicked the column heading. The second screenshot (bottom) was taken after I clicked the “IP Address” column heading.

    On the first screenshot, we can see there had 1 item in the list. On the second screenshot, it said “No items found.” The item still exists, because if I revisiting the 404 error log, it will reappears again.



    Hello, perhaps this below may help:

    [09-Jun-2014 15:37:33 UTC] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 for query SELECT * FROM g4_aiowps_events ORDER BY made by do_action('wp-security_page_aiowpsec_firewall'), call_user_func_array, AIOWPSecurity_Admin_Init->handle_firewall_menu_rendering, AIOWPSecurity_Firewall_Menu->__construct, AIOWPSecurity_Firewall_Menu->render_menu_page, call_user_func, AIOWPSecurity_Firewall_Menu->render_tab6, AIOWPSecurity_List_404->prepare_items

    I found the error message on /home/mysite/public_html/

    The error generated when I clicked the “IP Address” column heading.

    Plugin Author wpsolutions


    Thanks for the log Handoko.
    We will take a closer look and see what’s going on.

    In the meantime can you please tell me what the link looks like when you hover over the IP address column?

    I should be similar to this:

    Do you see anything like the above?

    Do you have any issues when you try sorting by any of the other columns?



    Sorry for this late reply.

    Here is mime, I right clicked and copied the link:

    All columns has same issue, the list became empty and said “No items found.”

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Bug Report:’ is closed to new replies.