Support » Plugin: Antispam Bee » Bug Report: 2.7.1 messing up viewport / breaks mobile layout

  • Resolved darkhydra90

    (@darkhydra90)


    Hi,

    I upgraded from 2.7.0 to 2.7.1 and all of the sudden the viewport of my website for mobile is all wrong (only on pages with comment forms). I tested across many tools and devices, even the google report tells me the viewport isn’t set for my site.

    Reverting back to 2.7.0 instantly fixed the problem. Did no other changes to the site.
    I’m using the default WordPress comment system. Disabled all other plugins to confirm it’s coming from Antispam Bee.

    So whatever code was added in last update might break the mobile layout’s viewport.
    Hope you can replicate and fix the error. My site uses responsive layout and runs on Genesis Framework. If you need more info let me know.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Simon Kraft

    (@krafit)

    Hi and thank you for your report.

    Would you mind sending us a link to your site?
    This will make it way easier for us to find an eventually fix the error.

    Cheers, Simon

    Hi, I’m using the latest version of Antispam Bee together with Generatepress and it messes up the mobile viewport.

    The problem is the hidden textarea which adds some extra width on the right side.

    You can see it on my site on any page with a comment field, e.g.:

    https://schlafwissen.com/kopfkissen/

    I temporarily fixed it, so just delete this CSS in the inspector:

    @media only screen and (max-width: 768px)
    .comment-form-comment textarea {
        display: block;
    }
    • This reply was modified 2 years, 2 months ago by toberoni.
    Plugin Support Torsten Landsiedel

    (@zodiac1978)

    Sorry for the late reply @toberoni!

    I can’t see any issues if I disable this CSS.

    I’ve added an Github issue for adding a padding reset (which is the problem with your theme here I think …).

    All the best,
    Torsten

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Bug Report: 2.7.1 messing up viewport / breaks mobile layout’ is closed to new replies.