Support » Fixing WordPress » BUG: posts_nav_link not working since 4.4.1

  • Hi all,

    I figured out a bug after upgrading to 4.4.1. I am constantly getting same posts when trying to “Load More” posts.

    I am using posts_nav_link function with multiple custom WP loops in masonry to load infinity posts. Every time I click Load More button, it loads same posts. It si not showing another posts page, etc. When I disable Javascript, it always shows me the same page with same posts, it’s not changing url to page 2, or something.

    Please, any help is appreciated since this is urgent and website is live. Thanks in advance!

Viewing 3 replies - 1 through 3 (of 3 total)
  • I am using posts_nav_link function with multiple custom WP loops

    You should post the relevant code. If it is more than a twenty or so lines, use pastebin, as per the forum rules.

    It does no good to mark your thread “urgent”. Everybody’s support request is urgent.

    Hi kjodle, thank you for the response. Yeah, you are right, excuse me I was just in a rush because of the client.

    So, here is the paste – http://pastebin.com/i4qiSZJY

    I have put there a piece of code where I am using custom loops. I have few more loops, I implemented exactly the same way, so I didn’t paste them in order to keep it cleaner. At the bottom is “Load more” button. Basically, it’s masonry with different post types.

    I am quite sure it’s up to WordPress update, because I had two WordPress versions, live was 4.4.1 and on the test server was 4.4. It was working properly only on test server, and after I updated to 4.4.1, it stopped working properly. That’s how I managed to see what was causing an error.

    I am looking to hearing from you!

    Update: I also tried with next_posts_link() function, and same thing. It’s not loading next posts.

    Only thing which worked is to downgrade WordPress to 4.4. Did it, and it is working again. What should I do besides downgrading WordPress version? Does anyone have same issues?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘BUG: posts_nav_link not working since 4.4.1’ is closed to new replies.