WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Bug: plugins don't load on homepage after update

[Resolved] Bug: plugins don't load on homepage after update

  • Hi there,

    After several plugins got updated yesterday I saw in the source code that actually no plugin is loaded* on the frontpage anymore. On all the other pages everything works just fine.
    The most obvious one is the menubar (wp-menubar-plugin), and for now I made an exception for the homepage** loading a hard coded copy of the menu as I couldn’t debug the issue.

    For comparison:
    – homepage: http://www.ehpress.com/
    – other page example: http://www.ehpress.com/specials/

    I tried some debugging by deactivating all plugins and activating one after the other with no change. I had a look through all my template files and couldn’t find anything that could cause this ‘exception’.

    Has anyone experience with this or a similar behaviour?
    I would be thankful for any hint where I could start with the debugging.

    Thank you for any help,
    Albert

    * the easiest test is the ‘All in One SEO Pack’ which should be found in the header
    **if (is_page('home')) … echo css and in the body echo html

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – switching to the default theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – increasing the memory available to PHP?
    http://wordpress.org/support/topic/253495#post-1017842

    Hi esmi,

    Thanks for your answer.
    I tried the theme switch and the memory increase without any result. When I tried to rename the plugins folder the server told me my FTP user doesn’t have the permissions (550 access denied). Waiting for the provider at the moment to sort that out.

    Hi there,

    I can’t exactly say what it was, but after the provider change some permissions so that I don’t get the 550 error again all the plugins work again as well.

    Thanks again for your help!

    Albert

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Bug: plugins don't load on homepage after update’ is closed to new replies.
Skip to toolbar