Support » Plugin: Redis Object Cache » [BUG] PHPRedis (pecl) does not work with TLS scheme

  • Code connecting through pecl client fails to make use of the WP_REDIS_SCHEME.

    For example, code under object-cache.php, line 465:
    Current code:
    $this->redis->connect($parameters['host']...
    Working code:
    $this->redis->connect($parameters['scheme'] . '://' . $parameters['host']...

    Thank you!
    Tim

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Did that ever work?

    It only worked after I prefixed the Host with Scheme (as I showed above). PHPResis 5+ supports TLS by prefixing the host with tls://hostname

    Plugin Author Till Krüss

    (@tillkruess)

    Right, but it hasn’t worked in the past with this plugin.

    I can confirm that it works flawlessly for me using the tls protocol. Look up the LSCache wordpress plugin on here. They do Redis Object Caching with support for tls via PHPRedis.

    My setup is Alpine + Nginx + Php-fpm + PhpRedis 5. I connect to the Redis server on DigitalOcean via tls protocol.

    If it makes it easier, I can put together a Docker image for you to test phpredis with working tls support.

    Let me know.

    Thanks!

    Plugin Author Till Krüss

    (@tillkruess)

    Can you submit a PR on GitHub?

    I’ve slammed with with the enterprise rewrite of this plugin.

    Sure! I am currently traveling. I will do that once I’m back home.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.