Support » Plugin: WooCommerce PayPal Checkout Payment Gateway » Bug: Paylink not working

  • Resolved espox

    (@espox)


    Hello,

    we found a bug.

    Situation:
    Client pay by paypal but it fails. So that we are sending the paylink again to the client by woocommerce -> orders -> order 12 (payed by paypal + status waiting for payment) -> Link “client pay page” (little blue hyperlink above the status input field). This link will redirect us / the client again to our checkout page where the customer can choose a payment typ.

    Bug: The payment is not working or the payment is working but the status of woocommerce do not change.

    Edit: Your Plugin is not integrated in the client payment page – isn’t it like that? We dont see the paypal express button here like when the client purchasing at first.

    • This topic was modified 3 months ago by espox.
    • This topic was modified 3 months ago by espox.
    • This topic was modified 3 months ago by espox.
    • This topic was modified 3 months ago by espox.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Joey – a11n

    (@jricketts4)

    Hi @espox – In order to show the PayPal Checkout option on the customer payment page for Pending Payment orders you’ll need to first ensure that Enable the PayPal Mark on regular checkout is enabled in your PayPal Checkout settings.

    Can you confirm that’s enabled?

    Thread Starter espox

    (@espox)

    Hey Joey,

    the paypal option is enabled but the paypal express button is missing (which is on normal checkout after purchase).

    If clients choose “paypal” on “client pay page” via link of the order page, the payment at paypal fails. that is the problem.

    It is working when you buy a produkt. It fails if we use the link of the order view.

    Thanks so far!

    Plugin Contributor Hannah S. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Thanks for that additonal information!

    If clients choose “paypal” on “client pay page” via link of the order page, the payment at paypal fails. that is the problem.

    I wonder if maybe you have multiple PayPal plugins on your site that’s causing this different behavior.

    Could you please share a copy of your site’s System Status? You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”.  Once you’ve done that, paste it here in your response.

    Thread Starter espox

    (@espox)

    Hello Hannah,

    thank you for your support!

    Can you sent me your support mail? I do not want to post such a file in pubic 🙂

    Plugin Contributor Hannah S. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Hey there,

    As this is a public forum, we can’t do things like moving to email.

    However, if you’d rather work on this further through email, you can create a ticket on WooCommerce.com. Please contact us at WooCommerce.com > My Account > Support. You may need to create an account before you can access that page.

    Please include a link to this forum thread, so that we can keep track of what’s already been done.

    Alternatively, if you’d like to keep working on this via the forums, you can post the system status report and remove the sensitive data such as the site URL.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.