Support » Plugin: ElasticPress » Bug or no-love for Third-Party/Self-Hosted?

  • Resolved vahanavagyan1

    (@vahanavagyan1)


    The “Elasticsearch Host URL” (called “Endpoint URL” on cloud.elastic.co) under the “Third-Party/Self-Hosted” tab. My Elasticsearch is up and running on the https://cloud.elastic.co and yet this plugin keeps throwing “There is a problem with connecting to your Elasticsearch host” error.

    That said, I’ve had a quick look and can see that my cluster is currently online and returning a bunch of HTTP 401 responses (authentication failures). I’m assuming that my server (via this plugin) lacks ANY credentials configured (since it didn’t even ask for any credentials) and the “Elasticsearch Host URL” is protected by username and password. Please advise.

    Since my Elasticsearch endpoint requires login/password, I am sure this plugin needs a username and password to access my Elasticsearch cluster but plugin shows nowhere to enter my credentials.

    Bug or lack of any support/documentation for “Third-Party/Self-Hosted” (or both?) users?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter vahanavagyan1

    (@vahanavagyan1)

    :/

    I have same issue.

    Using self hosted elasticsearch. The elasticpress plugin has no option for username and password. Entering credentials as shown in the below link in wp-config.php solution doesn’t seem to work.
    http://10up.github.io/ElasticPress/tutorial-security.html

    Plugin Author vhauri

    (@vhauri)

    Hi @vahanavagyan1 @jagadeeshvarma ,

    Per our pinned post on this support forum, we provide all support through Github. You can file issues at https://github.com/10up/ElasticPress.

    In order to confirm that the approach in the security tutorial is still working, I followed the following steps:

    • Set up a free trial account on Elastic.co with all default options (IO optimized, basic VMs, etc)
    • Enter URL for Elasticsearch from value copied in Elastic.co dashboard into WP/ElasticPress settings page
    • Confirm 401 response (expected as credentials have not been entered)
    • Set ES_SHIELD value as username:password based on values pasted from Elastic.co dashboard
    • Run a successful index.
    • Perform a test search on the front end, confirm I get a 200 result from my Elastic.co endpoint

    While Elastic.co does have a lot of options, this can cause confusion when trying to set up Elasticsearch (which itself is quite complex). While we do support the plugin side of a self-hosted solution, I do caution you that setup and maintenance of these servers can be quite difficult, which is why we built a service around this (ElasticPress.io) in the first place.

    Again, we will 100% stand behind our plugin and fix any bugs that exist in the plugin, but we cannot provide troubleshooting for individual connectivity issues with self-hosted solutions through Github or this forum. We do, however, provide custom consulting if you need to use a specific solution such as Elastic.co.

    • This reply was modified 1 year, 4 months ago by vhauri.
    • This reply was modified 1 year, 4 months ago by vhauri.

    @jagadeeshvarma
    Please don’t ask further questions on other peoples topics in these forums.
    This way you may cause unnecessary notifications being sent to various people. Instead: If you have a question, open your own topic for it. (Or, in this particular case – open it where you could expect to get answers.)
    I’m going to close this topic now.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Bug or no-love for Third-Party/Self-Hosted?’ is closed to new replies.