• Hi,

    I found an annoying bug on the “emails” settings page (Settings > WP-Members >Emails), on the body of any of the template, when there is a single quote character (‘), when you save the templates using the Update Emails button at the bottom of the page, the single quote characters (‘) are preceded by a backslash character (\’).

    This annoys me especially in French, where you frequently use single quotes.

    e.g. In the template, I have:
    “Nom d’utilisateur” (which means “Username” in French).
    When I save, the page is reloaded and the template is now:
    “Nom d\’utilisateur”
    When I save again, the template turns to:
    “Nom d’\\\’utilisateur”

    If you can please fix this issue.
    Thank you

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Chad Butler

    (@cbutlerjr)

    Thanks for letting me know. I have noted this for review.

    There is an update in the works that is expected to release soon, so it will be addressed with that update. But I’ll release a patch via a gist in the meantime.

    Thread Starter Tegomass

    (@tegomass)

    Awesome, thanks !

    Thread Starter Tegomass

    (@tegomass)

    FYI, as an “hotfix”, I’ve add stripslashes() function to wp_kses() in /includes/admin/tabs/class-wp-members-admin-tab-emails.php file.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Bug on the Emails settings page’ is closed to new replies.