Support » Fixing WordPress » Bug on “older entries” link at bottom of main page

  • When a users first accesses my site (brand new browser window)

    The “older entries” link comes up incorrect at the bottom of the main page. As a result, if anyone clicks on the link its comes back as a 404 request for an invalid page. The reality is that the link IS a valid page but just doesnt display properly. .

    Here’s an example of how should display:

    Here’s how it actually displays:

    You can see the root for the blog is duplicated.

    The odd thing is that this ONLY happens if the page is freshly loaded from a brand new window. If a user clicks on the home link in the header, goes to an archived month or if I log in as site admin, this problem disappers and the link appears properly. This is why I believe its a bug in WordPress not my setup. I’ve also tried different themes (default, Atahualpa, etc). All seem to do this. I’ve already tried disabling my wp-pagenavi plugin but this also had no effect.

    Its frustrating because when users look for older posts, they generally just go straight to the bottom of the page. Though its a small issue its an integral part of maintaining fluidity on my site.

    If someone can help resolve this issue (or find a workaround) it would be greatly appreciated.

    I’m using the IIS6 w/ Fast CGI 1.5 for IIS, & php 5.3.2 (all most recent versions)

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have this exact same problem and would love to know a solution to it as well. I have tried messing with the code in index.php for my theme and it has had no effect on the problem.

    I tried the following solution and it appears to have fixed my problem without breaking anything:

    In the link-template.php file, I found the function get_pagenum_link() that was supplying the incorrect url. I added a check to see if the blog username was being repeated:

    $pos = strpos( $base, $request );

    if ( !($pos === false) ) {
    $request = user_trailingslashit( ‘page/’ . $pagenum, ‘paged’ );
    } else {
    $request = ( ( !empty( $request ) ) ? trailingslashit( $request ) : $request ) . user_trailingslashit( ‘page/’ . $pagenum, ‘paged’ );

    This code is in place of:
    $request = ( ( !empty( $request ) ) ? trailingslashit( $request ) : $request ) . user_trailingslashit( ‘page/’ . $pagenum, ‘paged’ );

    I hope this helps!

    Garbles. you are our hero!!! This issue has been plaguing us for weeks. We are running on IIS 7 and using MS’s URL Rewrite and here is what we were seeing:

    1. When the trailing slash was absent in the blog URL, the “Older Links” was throwing a 404 error. It was rewriting the url. So our url was being re-written as:

    2. The trailing slash was also not being included in the blog URL when a user clicked on ‘Home’ in the navigation.

    3. When we added the trailing slash, the problem went away. All other links on the site were ok regardless if the trailing slash was present or not.

    4. We duplicated this issue in two different installs of WP and in two different versions of WordPress (2.9.2 and 3.0).

    5. The issue appears to occur only on the child blogs, but not the primary blog in a WPMU install. (I think this is right. We saw this true in one WPMU install but did not test it in the second.

    Your MOD here solved our problem. THANK YOU! There are many here at our organization who are thankful that you took the time to share this fix!



    I tried this solution and it didnt work.

    I found the issue and have a temporary fix for it but I’m not sure why it does this.

    Here what the issue ended up being. First a reminder that I have IIS 6.0 w/ PHP 5.2

    If I send someone a url with my blog address like below everything works fine.

    BUT if I send or someone types my address like follows

    Then my next posts links would send a 404 as noted in the initial thread.

    The only difference is the CAPITAL B in blog.

    Can someone confirm this is a wordpress issue?

    Robbie JW


    It’s probably the way your host works, it’s case-sensitive, not a WordPress issue. Unfortunately the only way I know of is to always use the correct case.



    No host. I run the site off my own server.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Bug on “older entries” link at bottom of main page’ is closed to new replies.