Support » Plugin: Comments - wpDiscuz » Bug on latest version

  • Resolved Soulrain

    (@soulrain)


    After updating to version 5.1.6, avatars disappear completely and some functionality is lost. This for example: screenshot. It’s the “Show replies” function and it doesn’t work at all when clicking.

    The error I get is
    SyntaxError: "JSON.parse: unexpected end of data at line 1 column 1 of the JSON data"
    for the file wpdiscuz.js.

    • This topic was modified 2 years, 7 months ago by Soulrain.
Viewing 15 replies - 1 through 15 (of 17 total)
  • avatars disappear for me also and shows “Reply” button even without login.

    Plugin Author gVectors Team

    (@gvectors-team)

    Hi @soulrain,
    Please delete all caches. If you have some booster, minifyer, optimizer or caching plugins, please reset all those. Even disable for a while to test it. before testing please press Ctrl+F5 and try it again.

    For the avatars please navigate to Dashboard > Comments > Settings > Cache Tab and purge Avatar caches.

    I have the same problem with the avatars, I am not shown any at all 🙁

    • This reply was modified 2 years, 7 months ago by furuba.
    • This reply was modified 2 years, 7 months ago by furuba.
    Plugin Author gVectors Team

    (@gvectors-team)

    Have you tried to delete avatar cache in Dashboard > Comments > Settings > Cache Tab?

    avatars disappear for me also and shows “Reply” button even without login.
    Also remove Wp cache and Dashboard > Comments > Settings > Cache Tab All…
    Doesn’t work

    Thread Starter Soulrain

    (@soulrain)

    @gvectors-team, I always do everything you suggested after an update, just to be sure. The situation is the same whether I clear caches etc. or not.

    For now I went back to version 5.1.5 but I’ll make a staging site to investigate further.

    Yes, just tried all the options you wrote above. Did not work.

    shows “Reply” button even without login.
    Users must be registered and logged in to comment (This option is enabled)

    Plugin Author gVectors Team

    (@gvectors-team)

    Could you please disable Avatar cache in Dashboard > Comments > Settings > Cache Tab? Also please leave some URLs to your website and a list of all active plugins would very helpful.

    • This reply was modified 2 years, 7 months ago by gVectors Team.

    Could you please disable Avatar cache in Dashboard > Comments > Settings > Cache Tab?

    Still doesn’t work and shows “Reply” button even without login.
    Users must be registered and logged in to comment (This option is enabled)
    Also remove Wp cache and Dashboard > Comments > Settings > Cache Tab All…
    Doesn’t work

    Plugin Author gVectors Team

    (@gvectors-team)

    Still doesn’t work and shows “Reply” button even without login.

    The right option is located in Comments > Forums > Edit form admin page.
    The doc: https://wpdiscuz.com/docs/wpdiscuz-documentation/getting-started/custom-comment-form/comment-form-settings/#only-loggedin

    How about information I asked? We need some info to help you. This is not a general issue and only exists on some websites, we need to see what’s unique on their websites.

    Allow guests to comment (NO)
    But Still doesn’t work and shows “Reply” button even without login.

    Plugin Author gVectors Team

    (@gvectors-team)

    Yes, we know about that and are fixing now. I just wanted to point you to correct option.

    Ok works everything well…
    What is “Enable WordPress native ajax”. Please ex-plane.
    Thanks for update and fixing.

    Thread Starter Soulrain

    (@soulrain)

    I can confirm that avatars are fixed in version 5.1.7 but “Show replies” still doesn’t work, neither does sorting by newest/oldest/most voted.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Bug on latest version’ is closed to new replies.