Support » Alpha/Beta/RC » Bug not fixed in 2.7 RC 2

  • Hi

    I attempted to upgrade to 2.7 RC 2 the tools>upgrade However when I went to wp-admin/post-new.php to add a new post and click on the tab, ‘Visual’ no cursor shows up and if I click and drag I see the HTML tag for line break </br>. However this HTML tag is only present when I click and drag.

    If I edit a post and click on the ‘Visual’ tab I see no text. However if I click and drag I will see the text along with the HTML tags. this bug makes it impossible for me to add any texts and I am disappointed that this issue has not fixed.

    I have done some initial testing with different browsers and all produce the same result but the cursor being visable in Safari.

    It is my hope that this error will be fixed when 2.7 is finally released.

    My blog is on a Appache server 2.2.10
    PHP: 5.2.6
    MySQL: 5.0.51A

Viewing 8 replies - 1 through 8 (of 8 total)
  • I want to be clear that adding a new post or editing a post that is live is not possible under the current release of 2.7 RC 1 & 2.7 RC 2. In previous releases 2.5 & 2.6 text issues have been an issue. If I remember correctly the issues centred around displaying texts correctly if it was copied and pasted from MS Word. In any event the fanfare that has surrounded this release has not held up if you cannot use the feature that allows you to enter your post. Hopefully this issue is resolved by the time 2.7 is released.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Works for me and I suspect many other people.

    Have you tried the usual of disabling all of your plugins and switching to the default theme? I’m not proposing you do this all the time, just once to determine if there is a conflict interfering with the visual editor.


    I have deactivated the plugins and I have switched to the default theme which has resolved the issue. The theme I was using was staypressed which has been a fairly dependable theme and would hate to have to rely on the default theme. Plus I would hate to give up some of the plugins that I use. So you are right there is something interferring with the visual editor.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Have you contacted the theme author?

    If switching to the default theme is what fixed your editor problem then the author may have an update to solve that one.

    Before the upgrade I was running 2.6.5 and all of the plugins with the theme ran fine. I have tried keeping the default theme and switching back the plugins back on with no luck. Also I have tried using the default theme and turning off a plug-in one by one with no luck. Third thing I have tried is turning off the plug-ins and using staypressed. I have received the same result the visual editor works fine. Right now to wonder what plugin or combination of plugins it could be. Is there a list of plugins that are not compatbile with 2.7 and if so can you please provide me the link?

    The issue I believe lies with the plugin or a combination of plugins. All plugins that I am running are from the site and have been announced on the dashboard. None of them are from 3rd party sites.

    For me the issue lies if I turn off the the plugins and use either the default theme or staypressed the visual editor works. For me this tells me the issue lies either with how the visual editor in WordPress interacts with the plugins or there is a plugin incompatibility issue with 2.7. For me a list of potential plugins that may not be compatible with 2.7 would be helpful or at least a class of plugins – (e.g. plugins that run stats). This is the reason why I advocate more stringent testing of plugins before announcing that a plugin is available for download on the dashboard and re-testing of available plugins before a new release is made available.

    Any insight that you may have as to which plugins are not compatible with 2.7 would be much appreciated.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    This must be happening more frequently since this URL appeared in the WordPress dashboard:

    Troubleshooting TinyMCE in WordPress 2.7

    I’ve looked at StayPress briefly and I don’t think it’s the theme.

    I’m not aware of a list of non-compatible plugins but try starting adding each one, one at at time, then you should be able to find the culprit.

    I have deactivated all plugins and began reactivating one by one using staypressed theme. Staypressed as a theme is quite dependable and after noticing that staypressed worked if all plugins were deactivate I decided to try again by activating a plugin one at a time. So far I have worked out that there are two plugins causing the problem with the visual editor which causes the visual editor not to display text: HeadSpace2 (which I love and quite disappointed to see that it is not compatible with 2.7) and RB Internal Link. At this point I have not determined if any of the plugins will cause problems with entering text or displaying it correctly once I press publish. At least I have been able to work out that two plugins have been causing the problem. The issue still remains is it the plugin itslef that is not compatible with 2.7, the combination of plugins that render it incompatible, or are there other factors contributing to it.

    Also I have looked at your posting regarding how to correct the problem. At least from my experience before writing in the forum I tried Firefox, Opera, Safari, and Internet Explorer with the same results with Safari yielding a slightly different result by displaying the cursor without displaying any text that has been entered.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Bug not fixed in 2.7 RC 2’ is closed to new replies.