Support » Plugin: Google XML Sitemaps » Bug: NoIndex Pages are being included in the XML Sitemap

  • Hi,
    The Sitemap is including pages that are set to noindex.

    I have multiple test, dev pages and woocommerce products that I’ve set to noindex. This is giving mixed signals to the search engines as on one hand the sitemap is saying we want the page indexed, and on the other hand the noindex meta tag is saying don’t index the page.
    The current exclude posts option is impractical for excluding many posts.

    Surely this is a major bug and needs to be addressed.

    • This topic was modified 4 months, 1 week ago by  JDTravel.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Same with me… Please resolve as soon… Why are you getting to much time?

    This page set to no index but showing in sitemap
    http://www.apunkagames.net/racing-games-for-pc/p2
    Please solve it as soon!

    Silky345234

    (@silky345234)

    Hi guys, authors of this plugin unfortunately dont respond.

    Therefore here is the workaround solution to fix this:
    1.In plugin settings go to Excluded Items – Exclude PostsGo and manually exclude number of pages that have noindex ..
    2.Re-generate sitemap
    3.Check the sitemap and noindex pages as they shouldnt be in sitemap anymore
    4.Resubmit the new sitemap to google search console
    5.Fix the errors in search console.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.