Support » Plugin: Vindi WooCommerce » Bug no gerenciamento de dependências

  • Resolved Casper Braske

    (@casper-braske)


    Olá. Mesmo após ter todas as dependências instaladas e ativas, o gateway continuava não funcionando e havia mensagens “O Plugin Vindi WooCommerce depende da versão %s do %s para funcionar!”
    Quando verifiquei o log, percebi que esse plugin procurava pelas dependências com o caminha da pasta de plugins “hardcoded”. No meu caso, meus plugins não estão em “wp-content/plugins”, mas numa pasta personalizada na raiz da instalação, como documentado do Codex.

    O problema se encontra em vindi-woocommerce-subscriptions/includes/class-vindi-dependencies.php:105. Minha solução foi usar a constante WP_PLUGIN_DIR:

    $plugin_data = get_plugin_data(trailingslashit(WP_PLUGIN_DIR) . $plugin['path']);

    Obrigado.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Bug no gerenciamento de dependências’ is closed to new replies.