Support » Plugin: Nextend Google Connect » Bug: Login/link with Google is no longer working

  • Resolved renet


    I just updated to the latest version of your plugin and it seems that you kinda messed up the Google login. Can you please take a look. When clicking the button, I get redirected to the same page (or the home page, if I used the buttons in the login form), but without being logged in / linked.

    A bit more QA for future releases would be appreciated! 😉

Viewing 15 replies - 1 through 15 (of 23 total)
  • I’ve got the same problem. The plugin stopped working. I click on the Connect button, i log in as usual, but then i get redirected back to the site and i’m not logged in.

    Same here !

    Guess I should have looked much here earlier. Spent the last several hours trying to figure out why the Google log-in wasn’t working correctly.

    Same problem as veribo and renet. The Google button takes me back to the homepage but without being logged in / linked.


    Same here


    I have find the problem, guys!!!

    – Open file nextend-google-connect.php.
    – Find in row 265 ( function new_google_login_action() ) this code:


    – and replaced with

    } else {
    	$authUrl = $client->createAuthUrl();
    	header('Location: ' . filter_var($authUrl, FILTER_SANITIZE_URL));

    The plugin will return to work properly!!!

    applied fix above – still no go – get error500

    yeah I tried and it didnt work for me either.

    Fix in my site works… 🙁
    Try to delete and recreate the Google application 😉

    @shecky – Your solution works also in my site. Thanks!

    damn, i just found out this plugin hasn’t been working for some time which is kinda bothersome.

    Tried the fix above but get an error also:

    The redirect URI in the request: did not match a registered redirect URI

    Any other ideas since the developers seem to have gone missing on this?

    Martin, error is caused by incorrect configuration of the Google application, not from plugin.
    Apply the fix I wrote above and delete and recreate the Google application: everything will work properly 😉

    @shecky, your fix worked perfectly for me. Thanks a million.

    Login on the demo site with a google account (chrome browser windows 7) does not work as it does not work on my own WP Site. Will you fix the problems some day?

    @shecky and all:
    Well, I finally got around to revisiting this.
    Deleted the Google App and did another per instructions.
    All is working again.
    No idea what happened as it was working before. Proves the plugin is fine and functional.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Bug: Login/link with Google is no longer working’ is closed to new replies.