Support » Plugin: Events Manager » Bug: Location name is required even when I select that there is no location

  • Resolved Tyler Tork

    (@tylertork)


    First thing after installing the plugin, create a new event. It is not possible to save the event; the following errors are displayed:

    Your event details are incorrect and cannot be published, please correct these errors first:
    Location name is required.
    The location address is required.
    The location town is required.
    The country is required.

    This is despite that the checkbox “This event does not have a physical location.” is checked, and therefore is it not possible to supply the required values.

    Please change your validations to not require location values on events with no location. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • TreeTrail

    (@aprilschmitt27)

    Tyler,

    You may want to create a location named: “No Physical Location” or “Provided Online Only”.

    ~April

    Thread Starter Tyler Tork

    (@tylertork)

    I suppose I’ll have to for now, but meanwhile you “may want to” fix the bug.

    TreeTrail

    (@aprilschmitt27)

    Tyler,

    Just to clarify: I am just a user. But I see this as a very logical requirement and not a bug.

    ~April

    Thread Starter Tyler Tork

    (@tylertork)

    Perhaps I didn’t explain clearly enough. There’s a checkbox that says “no location”. I check that box and it still insists I enter a location. It insists I enter values in fields which are hidden because I checked the box. This is a bug.

    Plugin Support timrv

    (@timrv)

    Hello,

    So far I have never experience those issue on all the versions. I don’t think it’s a bug but probably a conflict with other plugins or themes. Are you creating an event on front-end or backend?

    To minimize possible plugin/theme conflicts. Can you perhaps check the following?

    1. Make sure you’re using the latest EM and EM Pro Version
    2. Make sure your using PHP 7.1
    3. To minimize possible plugin/theme conflict, Could you perhaps try and Install WP Safe Mode (https://wordpress.org/plugins/wp-safe-mode/)
    – Activate and Enable Safe Mode. Please make sure that on the settings a twenty series theme is selected.
    – When activated it would help you test as if the Website only plugin activated is EM and twentyseries theme
    – After making sure that its working properly, You could start adding additional plugin on the list that is activated and test again until you see which plugin is causing the issue

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bug: Location name is required even when I select that there is no location’ is closed to new replies.