WordPress.org

Support

Support » Plugins and Hacks » bug – jQuery error when using with Pods plugin

bug – jQuery error when using with Pods plugin

Viewing 5 replies - 1 through 5 (of 5 total)
  • Is the Advanced Search by Solr Server plugin loading it’s JS on every single admin page apart from it’s own?

    Yes. It looks like the jQuery code block is being added to all admin screens via the admin_head action.

    I added an if statement around the jQuery code block so the code is only added when the solr settings page is displayed. This fixed the issue until the next version is released.

    if (isset($_GET['page']) && $_GET['page'] == 'MySolrServerSettings'):

    Plugin Author dbejean

    @dbejean

    Hi dwconcepts,

    Can you explain where exactly you put this line of code ?

    Thank you.

    So glad I found this…. Was driving me insane! I was commenting out the js and renabling when I needed to save stuff in the plugin!

    I added this

    <?php if (isset($_GET['page']) && $_GET['page'] == 'MySolrServerSettings'): ?>
    <script type="text/javascript">
    ==== REST OF JAVASCRIPT IN HERE===
    </script>
    <?php endif; ?>

    Seems to be working for me.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘bug – jQuery error when using with Pods plugin’ is closed to new replies.