Support » Plugin: Automatic Youtube Video Posts Plugin » Bug! Is Auto Generating Thumbnails x1000s (in media library)

  • I had been away from my WP dashboard for about 10 days. Then I opened my WP media library and saw thousands, yes thousands of youtube thumbnails saved there. It took over an hour to delete them all using bulk delete.

    Then I tracked down the trigger… I list my videos based off a WP Tag “videos” and so when someone visits: mysite.com/category/videos/ they get a list of my YouTube videos, BUT this is precisely what was causing all the YT thumbs to automatically be entered into the media library. -yikes

    Next I traced this huge problem back to this very plugin. I deactivated the plugin and no more YT thumbnails have been generated automatically in the media library.

    I’m using the free version of Automatic Youtube Video Posts Plugin on the genesis framework and would love to hear back from the developers about this.

    https://wordpress.org/plugins/automatic-youtube-video-posts/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author ternstyle

    (@mpraetzel)

    Hi, bionary.

    The way the plugin works is, the import of the videos takes places. Then when the_post is called for the video post in either a WordPress post loop, or when viewing the post, the plugin checks to see if the featured image is set. If not, it imports it. If it is set it should NOT import it.

    Is the featured image set for a post that has had its featured image imported more than once? Are the images being imported more than once?

    Here’s what I do know. I’ve used the plugin for years without this problem and only recently did it start adding tons of images to my media library. Yes, there are repeats. No, I do not have any featured images set for the posts, I never did. I haven’t made a new youtube video in quite some time.

    Plugin Author ternstyle

    (@mpraetzel)

    Try changing line 26 of /front/thumb.php from this:

    add_action(‘the_post’,’WP_ayvpp_add_post_thumbnail’);

    To this:

    //add_action(‘the_post’,’WP_ayvpp_add_post_thumbnail’);

    Thank you for your speedy response. I’m not comfortable changing source code because won’t the break when I update in the future?

    Plugin Author ternstyle

    (@mpraetzel)

    It eon’t break, per se. However, yes, you’d need to make this change after every upgrade.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bug! Is Auto Generating Thumbnails x1000s (in media library)’ is closed to new replies.