Support » Plugin: WooCommerce PDF Invoices » [bug] Invoice column always shown

  • Resolved JorritSchippers

    (@jorritschippers)


    The Invoice No. column is always displayed, even when I disable the option on the settings page.

    This is because of the following code:

    if ( ! isset( $general_settings['bewpi_invoice_number_column'] ) ) {

    $general_settings['bewpi_invoice_number_column'] is equal to "0" and as such isset() fails.

    The following code makes it work:

    if ( empty( $general_settings['bewpi_invoice_number_column'] ) ) {

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi,

    I’m having the same issue when trying to disable the invoice column.

    The following code makes it work:

    
    if ( empty( $general_settings['bewpi_invoice_number_column'] ) ) {

    Do you have any idea where to change this?

    Cheers.

    Plugin Author Bas Elbers

    (@baaaaas)

    Thanks. I’ve fixed it.

    Would you be so kind to rate the plugin? It will support future development a lot! Many thanks.

    Thanks for applying the fix this quickly!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[bug] Invoice column always shown’ is closed to new replies.